Cracking, skipping, and distorted sounds when I record.

I am using a focusrite scarlett usb audio interface with updated drivers directly from the manufacturer’s website. I have uploaded videos to youtube to show what kind of problems I’m having. When I use audacity to record, it sounds like this

Here’s how it is supposed to sound

In both videos, the input sound was coming from my Yamaha MO8 to my usb audio interface, and then into my computer. The only differnce is that in the first video, I used Audacity to record the sound and in the second one, I turned on my webcam and changed the input sound source to be the usb audio interface instead of the webcam (Yamaha MO8 has no onboard speakers so recording with a microphone is not an option. I can only record through the USB Audio interface).

As you can see, the sound is very distorted and it skips a lot (I played both of these at about the same tempo, yet the audacity version sounds much faster).

I have tried changing the recording to 16bit and I turned off the “update display while playing”.

I am using Audacity 2.0.2. I downloaded the exe.
I am using windows 7 home service pack 1 (64 bit)
I am recording from a Yamaha MO8. I have two 1/4 inch jacks going from the Yamaha to the focusrite scarlett. From the focusrite scarlett, there is a usb cord going into my computer and some headphones that I use for monitoring (if I record without the headphones connected I still have the same problem. I also have the same problem if I only connect one of the 1/4 inch jacks).
I have 8 gigabytes of RAM. My harddrive has over 500gb of free space. I have a quad core processor (1.9gHz each).

The main difference is your camcorder is a purpose-built recorder and your computer isn’t. Are you going into a USB hub at the computer?

We don’t have anything that directly addresses this other than the fuzzy overview that the computer isn’t going fast enough to capture the work. A particularly aggressive virus protection system can do that. It tries to inspect everything on the way to the drive. Can’t do that with live audio (or video).

I think there’s still Windows Sound Recorder, right?

– Windows Sound Recorder
– Start > Programs > Accessories > Entertainment

Try that.

You can also try “reinstalling” Audacity.
Scroll down to Resetting Preferences (you don’t actually reinstall Audacity).


Oh and remember to plug in all the USB stuff and Then start Audacity.

One more, do you leave Skype running in the background?


It was the antivirus. I can’t believe I didn’t think of that. Over the past few hours I’ve been trying other programs and I’ve had the exact same problem with FL Studio, and Ableton Lite Live. Then I tried in Adobe on a friend’s computer. The fact that he and I use the same antivirus software (avast) should have clued me in. I guess Avast ignores cyberlink, which allowed me to record the video, but interfered with everything else. As soon as I turned Avast off, I was able to record just fine in FL Studio and in Ableton Lite. I’m guessing it will work in Adobe too, though I can’t test that right now.

Thank you so much for the help.

I had wrote a post about how turning off the antivirus fixed the problem, but I don’t see that post anywhere. Maybe I forgot to hit the submit button.

Well, turning off the antivirus program (avast) seemed to have fixed it temporarily but the problem has come back and disabling my antivirus software no longer fixes it.

I’m not using a camcorder, by the way. Both of those videos I posted were recorded on my computer. In the first video, I used audacity. In the second, I used cyberlink, which records both video (through my webcam) and audio (through my usb audio interface). So the only difference between the two videos posted is the software used.

Windows sound recorder works fine. I do not have skype running. I actually reboot my computer and make sure nothing is running at all whenever I’m doing this. I tried completely reinstalling audacity, but that did not work.

Thanks for letting us know the outcome.

Avast does not normally interfere with Audacity, though I guess it could do if you have it set for high security.
If you configure Avast to ignore “.AU” files and not to run any scheduled scans while you are working, then it will probably leave Audacity alone to get on with its job (worth trying).

The delay in your post appearing is because posts go into a “moderation queue”. This has unfortunately become necessary so as to prevent the forum from being flooded with spam messages.

Ah, okay. That explains why I didn’t see my post.

Well, the problem still persists and it isn’t being caused by my antivirus software. At this point, it’s safe to say that the problem is not with Audacity either. I’m just going to return my usb/audio interface and get a different brand.