Could not open MP3 encoding library

Hi, I am using Audacity 2.0.3 for Mac on system 10.6.8. I recorded a 1-minute audio with voice and music. I exported it but I get a message saying it can’t open the MP3 encoding library. I have Lame and the Lame Librar v3.98.2 for Audacity pkg, is it too old? I was able to encode one last week on the older Audacity version I had, but it wouldn’t work today, so I upgraded to the new version and it still doesn’t work.

I suggest forgetting the DMG package of Audacity, as Apple sometimes locks the folder to which the package installs LAME. This stops Audacity using LAME.

Try the zip instead, following these instructions: .

If you extract libmp3lame.dylib to the folder the Audacity application is in, then restart Audacity, you may not need to open the Libraries preferences to browse for the dylib file.


Thanks, Gale. But that didn’t do it.

I tried following your instructions at

I followed the directions until the last step, ie, I clicked Audacity>Preferences and then chose “Libraries” on the left; I clicked “Locate…” under “MP3 Export Library,” then “Browse…” in the “Locate Lame” dialog. The “Where is libmp3lame.dylib?” window opened; however, the instructions say that it will open at /usr/local/lib/audacity but what came up in that window (“Where is libmp3lame.dylib?”) was “Aucacity 1.0.3” and the only choices were “install.txt” (grayed out, unavailable) and the Audacity folder. This seems to be an infinite loop.

Then I tried your suggestion of extracting the contents of the zip to the folder the application is in, which is the drive for Audcity 2.0.3. (The earlier version of Audacity was in my Applications folder; this one did not go there when I installed it; instead it is on the left side of the finder window under Devices.) But it will not go in there. I can’t put it in. So that’s not going to work.

So I tried the Alternative zip download method on the page of instructions you sent me to. Again, I got to the last step, ie, I downloaded and extracted the contents of the zip to a folder called “Lame_Library_v3.98.2_for_Audacity_on_OSX” on my desktop; I clicked Audacity>Preferences and chose “Libraries” on the left; I clicked “Locate…” under “MP3 Export Library,” then “Browse…” in the “Locate Lame” dialog; I navigated to my desktop and opened the folder I extracted the zip to, and selected “libmp3lame.dylib”, and clicked “open.” But there was no option to click “OK” and “OK.” Instead, a window titled "Terminal — 80x24 opened, with the following dialog in it:

"Last login: Thu Feb 21 19:35:27 on ttys000
/Users/macbookmacbbok/Desktop/Lame_Library_v3.98.2_for_Audacity_on_OSX/libmp3lame.dylib ; exit;
macbook-macbboks-MacBook:~ macbookmacbbok$ /Users/macbookmacbbok/Desktop/Lame_Library_v3.98.2_for_Audacity_on_OSX/libmp3lame.dylib ; exit;
-bash: /Users/macbookmacbbok/Desktop/Lame_Library_v3.98.2_for_Audacity_on_OSX/libmp3lame.dylib: cannot execute binary file

[Process completed]"

So, it didn’t work. Just to be sure, I went to Audacity and tried once again to export as MP3. Results were the same as before I did all this, I got that same message: “Could not open the MP3 encoding library.”

What should I do now?

Personally if I were on a MAC I would be using iTunes to do the MP3 conversions for me.

You can import WAV or AIFF into iTunes and then convert them to MP3 or AAC or whatever (you’ll need to fiddle with your import settings). Note that iTunes makes an MP3/AAC copy leaving the WAV/AIFF intact.

Even as a PC user on Windows I do this as:
a) it avoids having to add the extra libraries (LAME, FFMpeg) to Audacity,
b) it keeps me strictly legal (I assume Apple is handling the Frauenhoffer licensing for MP3 conversion),
c) iTunes does it quicker tha Audacity,
4) it provides me with a WAV file to back up and archive.


That description suggests you are running Audacity from the DMG installer, so the “Browse” window opened in the DMG.

If so you will need to install Audacity properly according to those instructions in install.txt before you can use it properly.

1 Double-click the downloaded .dmg to mount it (if it is not already mounted)
2 Then to install Audacity, copy the “Audacity” folder from the newly mounted DMG to /Applications
3 Unmount the DMG
4 To launch Audacity, double-click its icon in the /Applications/Audacity folder.

If the old version of Audacity is still in /Applications, drag its entire “Audacity” folder to Trash.

Then install Audacity as above from the DMG (and apparently as you did before).

Please install Audacity properly as above. I think the Terminal window opened because Audacity cannot open LAME when you are running Audacity from inside its installer.

If there are still problems opening LAME from ~/Desktop/Lame_Library_v3.98.2_for_Audacity_on_OSX when you are running Audacity 2.0.3 from /Applications/Audacity, try copying the libmp3lame.dylib file into /Audacity/Applications then restart Audacity.