Copy-paste from one project to an other


I am a school teacher and I make an audio serie with children (7 to 11 years).
I work on a mac that runs on Linux and OSX.
For a moment, I could not have a dual boot so I had to work on OSX …

We had a project for each character and a project for the final.
We worked with a dual screen, so it was very easy to open diferents projects (corresponding to the characters) and paste the good extracted in the final project.
Since, I could (finally) boot Linux (Ubuntu 14.04 - Audacity 2.0.5). But I have some problems:

1- It is more difficult to open several occurrences of Audacity. (You have to go to menu “open” (a project) … No more double click so convenient !!!:frowning: ) We open and close projects regularly …
2- More importantly, copy and paste saving a project to another is not working !!! :astonished:

With so many lost ergonomics, I may be forced to resume making children work under OSX !!! :blush:

Anyone know how to enable copy and paste from one project to another? (It was up to 6 characters + sounds + !!! music :mrgreen: )

Thank you very much !!!


It is a known Audacity problem on Linux. If you want to try recompiling Audacity , there is a patch for the problem you can test: . As you see, there is a report there that the patch may cause a crash in Ubuntu 14.04 but I have not tested that yet on that version of Ubuntu.

What exactly happens when you copy and paste as you did on OS X?


I’m on Debian and it’s working fine here.
Could you give steps to reproduce the issue.

Hi !

Thank you for your answers :slight_smile:

there is a patch for the problem you can test: > > .

I just saw that there is a 2.0.6 version. I will try it :slight_smile:

What exactly happens when you copy and paste as you did on OS X?

There is just an empty selection that appears…

Thank you.

I will try 2.0.6 and i’m back.


If you merely compile the 2.0.6 source tarball, or install the latest PPA source code package (currently the same code as the 2.0.6 tarball), you will still see the old behaviour. If you double-click an audio file type Audacity is associated with, you will still see “Audacity is already running”. To see the patched behaviour you would have to download the tarball, patch the source code then recompile Audacity.

I tried the patch on 14.04 yesterday. It does not crash for me.

Is the audio you are pasting from WAV files that you have moved, renamed or deleted?


Thank you very much…

I wil see what I can do… But I’have not a great experience with compilation… :unamused:


Sorry, the compilation is too difficult for me… I’m juste a primary school teacher… :neutral_face:

But we are using now the svn ppa and we don’t have the “no paste bug” any more with this version : Audacity 2.0.7-alpha-Oct 12 2014 :slight_smile: It was the worst problem…
We have yet to open one per one each project, but it is working ! :slight_smile:
Do you know when the patch will be intergrated in the svn version ? :question:

Thank you for all


No-one except you has reported that problem, so nothing explicitly was done between 2.0.5 and 2.0.7-alpha to fix it. If Audacity pastes an empty selection that suggests it does not have access to the audio.

The patch for importing another file by Open with? I would like to see that patch applied. A developer said he found a crash, but I have not seen that.