Conversion Format Issue

I have the need to often convert to mp3 (from flac, etc). When using “export multiple” it always adds the track number to the file name. I’ve tried all the settings i can see but no luck getting it to stop this behavior (which forces me to have to re-edit each and every file after the conversion). I’ve attached an example and circled the track number i do not want written. In other words, i just want just the track name in the “track title” field, not the track number…otherwise i have to manually remove it from every file.

thanks Tom

Forgot to add (i could see no way to edit the post) i’m using Audacity 2.3.0

I believe that i have tried every setting i can find with no solution. I have noticed that exporting just one file audacity does not add the unwanted change (perfect! except it would take me days to make all the edits necessary to remove the unwanted changes). It’s only when exporting multiple that the program alters the ‘track title’ field.

Are you trying to batch convert several files to mp3?
Did you try using a macro?

Hope I’m understanding the situation. If not just ignore my reply.

Thanks for the reply.
Yes, using the ‘export multiple’ feature. I just want to export without audacity altering my file names. The export multiple seems like a time saving feature, but if you have to re-edit each file to get back to square one, i see no point, it likely would take longer to correct the unwanted changes than the time saved using batch export!

Just wanting to find out if i am missing something. Hopefully i’m overlooking a way to batch edit without the program making unwanted changes to the name of the files.
thanks t

I do not have this issue with 3.1.0 (or with 2.4.2).

Any chance of seeing/getting your settings? See above image (earlier post) for my settings, are yours the same/how do they differ?

thanks, Tom

So I did Tools > Reset Configuration before I started. Then I observed that in Edit > Metadata all tags were blank before I started. And I did not enter any Metadata manually.

As you did, I specified Split files based on Tracks; however I left all the other options unspecified, so .WAV files, not MP3 files, were created. Do you suppose that could have made a difference?

Thanks for the help,
I don’t see where ‘Reset Configuration’ it’s not under tool in my version. I guess it’s not so important anyway as starting with no tags is even more work than having to re-name one tag!

What i’m trying to accomplish, and i suspect it is possible, is to convert files that i have already tagged correctly (ex: flac to mp3). I want the tags to remain the same during the conversion. They do for the most part except for one change that Audacity makes. It adds the track number to each files name. And by that i mean, it adds the number to the file name field, not the track number field.

I’m looking for a way to stop Audacity from making this odd change (why leave several tags alone and make a change to just this one?).

Thanks for any help you can lend, Tom

You may not be able to get this to work in 2.3.0. Have you tried a more recent different version of Audacity?

As I said, this works for me under 2.4.2, which you can download here:

It also works for me under the current 3.1.0, which you can download here: