Constant High Pitch Hum

Using 2.0.2, downloaded as dmg, with Snow Leopard on a fairly new iMac.
I’m running my mic via a USB mixer in, and when I click on the monitoring, there is the constant whine, with nothing else playing at all. I don’t know what’s causing it, and really, don’t know where to begin. Could it be the USB cable, do I need to not be connected to the internet, or have any devices plugged in? Altho, I did use Audacity a month ago, with the same mixer, and didn’t have the issue with the hum, which is why I’m now confused…

Also, I couldn’t find any info as to how I can hear what’s already recorded, (I have my Mac set to Built-In Output). I’ve tried running it into the “2-track” RCA inputs, but then the tracks get recorded along with my sax going thru the mic. I’ve tried plugging into that AUX ins, and that works, but to turn it up loud enough to hear in my headphones, that high pitch hum gets too loud. So basically I just need to get rid of the hum, any ideas???

What’s your USB device?

You seem to have a jumble of symptoms. That may have been caused by one tiny thing that exploded into a series of patches that conflict. If you turn up a USB connection far enough, chances are you may hear a digital whine, but that’s supposed to be so low that nobody hears it.

Download this short piano selection, restart Audacity, import the clip and play it. That’s what the blue waves and bouncing green meter are supposed to look like.

If you can’t hear it, use the Audacity speaker pulldown on the main Audacity window and select Built-In Output. Now you should be able to hear it through the iMac’s tiny built-in speakers.

When you perform into your mixer and record to Audacity, do your red recording meters go up as far as the green meters on the piano piece? I’m betting not and that’s where your noise is coming from.
So now you get to tell us all about your mixer, the microphone, the connections, etc. etc. Does your mixer go through a USB hub?


Hi Koz,

I’m using an Alesis iMultiMix 8 mixer, a Sennheiser 441-U mic, with no USB hub. The levels are all cool, and when I listen back, I’m not really hearing the hum. But when I have it in Record (paused), even with nothing playing, there’s movement on the sliders & you can hear the whine. I am having also the issue of hearing some of the initial tracks on the track I’ve recorded my sax. I can’t figure out how to listen to the tracks, while not having them come out on the new track.

Thanks for the extra information.

Do you like to record internet audio with soundflower or other software?

I’m assuming you’re using the Overdubbing feature and you’re playing an instrument against a rhythm or other existing track.

I think I can help with the last one. Audacity will play anything visible. Any timeline with music on it will play however many you have stacked up unless you SOLO or MUTE – the little buttons on the left of each track. MUTE just kills that one track. SOLO kills everything but that track. If you push both the computer will explode.

Just kidding. I don’t know what happens if you push both – but they are contradictory.

Audacity > Preferences > Recording > [ ]Playthrough (de-select). Both playthroughs should be deselected for overdubbing. You cannot hear yourself right by listening to the computer. Your real-time performance in your headphones will always be “one computer late.”

Did I catch enough variables?


  1. I do use soundflower to record internet radio or talks, etc. But I just use Quick Time for that stuff…

  2. Yes, I’m overdubbing on some instrumental tracks

  3. I know how to use the mute/solo buttons

  4. I read that to hear while you record to use the software playthrough, and I’ve tried using the audio out, plugged into my aux in, as well as the tape in, and in both cases I hear the tracks, but they get recorded on the channel I’m recording my sax onto. That’s the problem, and I know there must be some way. I’ve gotten around it in the past, by using some wireless headphones to hear the tracks, then wearing some ear buds underneath them, monitoring my mixer, so I can hear my horn. That works, but is a bit of a hassle, and I know there must be a way to do it that’s simpler… By the way, when I did use the playthrough, I had no issue with latency…

By the way, when I did use the playthrough, I had no issue with latency…

You’re the one. Most of us have just enough Playthrough Latency that you can’t sing or play to the original tracks.

Oh, and you have feedback the way you’re doing it.

Anyway, you need two mixers – or two independent mixing channels inside your one mixer. You need a headphone mix consisting of the playback of the original selected channels plus your live performance. Full Stop.

You need a show mix consisting of your live instrument performance and nothing else. Full Stop. You cannot cross those.

Some mixers have the ability to generate an Effects Send and you can use that as the headphone mix. Describing this is a little like the five volume set, “How To Ride A Bicycle.” Input strip one consists of your microphone. Input strip 2 consists of Audacity Playback.

Send both of those out of the mixer using either the Pre Fade Mix or the Effects Send. Anything that grabs the sound before the main mix bus.

Only turn up the fader with your live performance on it for the rest of the mixer and out to Audacity record. Leave the fader with the Audacity playback on it down.

So that gives you two independent shows, the complete mix for your headphones and the Sax by itself for overdub recording. And no feedback.

In the three hardware solutions we wrote about, the USB device does all the headphone mixing divorced from the show. That’s how you can get two different shows, and those solutions do have zero latency for everybody.

For one example:


Ok, it sounds pretty complicated, and I don’t see how that eliminates the hum/whine, as it does that even when I’m doing nothing but monitoring the input, with nothing going on, no tracks playing. I also don’t hear it when I’m monitoring just my mixer, while Audacity sits still. So, something somewhere is creating that noise, as the red slider goes to about 25 - 35% whenever I click on the monitor level. So it’s either coming from the computer or program, or from my mixer, (altho I don’t hear anything via my mixer headphones, nor is anything showing up on the mixer’s monitor graph. I may just go on ahead and record with it as is, cause you don’t hear it when listening to the sax, and my producer could probably edit out any noise on silent parts with his software… As for the mix, I’m just using the ear buds/headphones method, as it works…