Connot get Audacity 2.0.6 to work [SOLVED]

Have been using Audacity 1.2.6 on my desk top with Windows XP and have no problems. Installed Audacity 2.0.5 on my laptop with Windows 8.1 and had problem but got help an got it working. Install Audacity 2.0.6 and cannot get it to work. I am using a Innovative Technology USB Turntable. as soon as I click on the record button I am getting weird sounds coming out of the speakers with or with out the turntable connected. What do I need to do to set up 2.0.6.

It’s a pretty sure bet you’re not recording from the turntable. Remember to plug the turntable in first, let Windows recognize it and then start Audacity.

had problem but got help an got it working.

What was the help? “Select the turntable in the Device Toolbar?” That sounds an awful lot like the problem you have now.


Maybe windows is not recognizing the turntable. I plugged the turn table into my desktop with Windows XP and got a chime and brought up Audacity 1.2.6 and it worked. When I plug my turntable into my laptop with window 8.1 I notice I am not getting a chime. I plugged a flash drive into the same port and got a chime indicating the port is working. Tried another port and the same. What can I do to make it recognize the turntable? I tried restarting the laptop and no luck.

Does the turntable support Windows 8.1? Have you tried replacing the USB cable?


Got it working last night. Plugged in the turntable to USB and reinstalled 2.0.6 and did the reset and rescan and it recognized the turntable. Thanks for pointing me in the right direction.