Connecting recording device

Hello, I would be so glad to get some help! I cannot make the recording unit connect as it should… it is a device for transforming cassette recordings into digital tracks, it is called BaseTech, it looks like a walkman, and it is connected by usb to my computer which is a MacBook MacOS Catalina 10.15.7. My Audacityprogram is version 2.4.2. I have checked all the configurations as says on the Audacity help guide when this kind of problem occurs and still there is no soundtrack being made when I press record. I mean the recording is running, but there seems to be no input although I can hear the music from the walkman. My recording unit in Audacity is set as USB Microphone. What is wrong?

Go to Apple menu > System Preferences > Sound > Input. From the list, select your cassette-to-USB device. Play a cassette. Does the sound input meter bounce?

I am surprised that it is listed as “USB Microphone”. Would it perhaps be “PnP USB Audio Device” or similar?

– Bill

Thanks for your reply! When I do as you say the sound input meter does bounce. But still no recording is created in the Audacity program.

What do you mean by PnP Usb audio device? My device is a USB cassette encoder named BT-USB-Tape-100. It came with a CD with software, but I haven’t been able to use it since my computer is lacking a CD reader. Tried to find same software online to download, but couldn’t find any… is that the problem?

So you see “BT-USB-Tape-100” in the input list in Sound Preferences?

According to the manual for this device the CD just contains a copy of Audacity (probably a very old version), so that is not the issue.

In Audacity, if you select the “Internal Microphone” as the Recording Device and make a recording, does it work?

– Bill

No, in the input list in sound preferences it says USB microphone… not the name of my device.

In Audacity, when choosing Internal microphone, still no recording is being made.

Go to Apple menu > System Preferences > Security and Privacy > Privacy.
Click on “Microphone” in the list on the left.
Is Audacity listed (with a checkmark) in the list on the right?
– Bill

It wasn’t. It was listed but without a checkmark, so I changed it and now it works! Thankyou!!