./configure error Fedora 11 - "requiers expat to be enabled"

Hi all,

I am trying to compile audacity on Fedora 11 because I need MP3 support. I have dealt with most dependency issues as they arise by install the relevant devel packages with yum, except it appears for expat. I have install every package with expat in its name.

compat-expat1.x86_64 : A library for parsing XML documents
expat.i586 : An XML parser library
expat.x86_64 : An XML parser library
expat-devel.i586 : Libraries and header files to develop applications using expat
expat-devel.x86_64 : Libraries and header files to develop applications using expat
expatmm.i586 : C++ wrapper for the expat XML parser library
expatmm.x86_64 : C++ wrapper for the expat XML parser library
expatmm-devel.i586 : Libraries and header files for expatmm


What am I missing or is the version of expat that comes with Fedora 11 not compatible? I looked on the wiki and it implied that almost any expat library should work as long as it is not too old. I am not sure how else to investigate this problem further. Any help appreciated.

Regards

Mark

mxc,

I am not a current Linux user but I am surprised that no one has yet responded to your query.

Check out the following thread: Ver 1.3.7 won’t open MP3 audio on Fedora 11 install.

I hope this helps.