Computer sounds are included in recording?

Hi, I’m sorry if this message isn’t too clear and I may not be great at troubleshooting, since I’m not a computer expert and barely have any experience with recording, but hopefully someone can work with me to solve this problem because it seems simple.

I’m using Windows 8.1 on an Asus netbook, with the latest version of Audacity (2.0.6). I’m using it to record acoustic guitar with the built-in computer mic. (I realize this isn’t an ideal way to record but I don’t want to invest in gear until I’ve played around with recording a little bit and proved to myself that I enjoy it enough to spend money on it.) Anyway, it sounds fine in every way but one: I use a metronome on my computer to keep time, which I’m listening to through earbuds, and obviously I don’t want the metronome to be in the recording. It’s much fainter than the sounds coming in through the mic, but it’s totally detectable and it sounds bad. (I tested it out with other sounds like a YouTube video, and got the same results.) How do I change the settings, either in Windows or in Audacity, to stop all computer sounds from recording and ONLY record what is coming in through the mic?

I tried searching the Audacity help files and forums, but I didn’t find any clear answers that helped me. I did check the Microphone settings: “Listen to this device” was not checked, and there were no other relevant settings that I could find there. I tried to look for sound driver settings, but all I see is AudioWizard and SmartAudio which didn’t seem at all relevant when I clicked on them - am I looking in the wrong place?

Also, if I’m remembering correctly, I never had this problem with earlier versions of Windows.

In the device toolbar, set “host” to MME and the “recording device” to your microphone (not “Stereo Mix” or “Sound Mapper”)

Thanks, but it was already on that setting. Do you know what else could be causing it?

Take the earbuds out of your ears (but still plugged into the computer). Can you hear the metronome? If you can, then so can the computer mic.