compressor deleting wafeform


I have been using audacity to edit podcasts for a number of years but use the same basic functions and tools over and over and so I am not particularly experienced from a technical perspective.

Tonight I imported a wav file and, as normal, tried to use the standard compressor as a first step. I have not changed any settings but for some reason after it applied I was left with a no waveform. It is as if it deleted the file.

I reimported and tried again but the problem remined. I updated audacity to the latest version, but no luck. I have been performing the same steps for about 6 years and have no idea why this has suddenly happened now.

I am using windows 10 and the recording was made on a mixpre 3 mk2.

Any help on this would be very much appreciated.


What version of Audacity and what compressor settings? (A high compression ratio and a low threshold can compress-down to almost nothing.)


3:1, -16DB

The whole waveform disappears. There is nothing.

Well… I can’t explain that…

But that seems like an awful lot of compression, unless your peaks are not too far above the -16dB threshold.

And you are using built-in compressor effect, right? Effect → Compressor? And it looks like [u]this[/u]?

yea that’s what I am using. thanks for your time anyway.

What settings are you using? (all of them)

Roughly how big is the waveform before applying the Compressor? (a screenshot might be useful - see here for how to attach the screenshot to your post:

How long is the track?
Mono or stereo?
Do other effects work as expected?

Ken, can you post a 10 second sample of the .wav file here that illustrates your issue ?

Thanks guys.

Not sure what caused it, or why it fixed it but I deleted the fist sec of the file and this allowed me to compress as normal.