Complete newbie recording question


I am using Audacity 1.2.6 and an XP PC.

What i am trying to do is record my electric guitar. So i have my guitar plugged direct into my PC (no amp etc) via the line in socket.

I start up audacity and i can record my guitar no problems, so the sounds not great but i can add effects via a vst plugin i have and it sounds ok to send to a freind of mine so that he can hear what i have in mind.

Now the part im stuck with, i want to record another track over my first, so for example i record my first guitar part and now want to record another part (lets say a guitar solo) on another track. I set my preferences so that audacity has the ‘play other tracks whilst recording new one’ set active.

What happens is that i get a copy of the first track recorded onto the second track.

I ahve read some of the forums and googled but cant get a straight setp by step answer as to how to overcome this. My sound input and output is set to ‘Realtek 97 Audio’ in audacity for playback and recording. I suspect something to do with that.

If anyone can be of any help it would be great as im stuck. Maybe it cant be done with this software.


You’ve got it in one :slight_smile:
I’m not able to give you a step-by-step, because the Realtek drivers are a bit different from others, and I don’t have one. However, I think I can point you in the right direction.

If you look in the sys tray (bottom right hand corner of the screen) you should be able to find an icon that looks like a loudspeaker - a single click on this will bring up the volume control, and a double click will bring up a Mixer Window. This may be the standard Windows Mixer, or it could be a custom Realtek control panel thing.

If you don’t have a loudspeaker icon, you will need to look in the Windows Control Panel, under “Sound and Audio Devices”.

The reason that you are getting the first track transfered to the second track is because you have your recording input set to record “What U Hear” (also called “Stereo Mix” or just “Mix”). This is great if you are wanting to record internet radio, because what it does is to record whatever gets sent to your speakers. However in your case, track one is being sent to your speakers and you don’t want to record that. So what you need to do is to change the recording source (in the Windows Mixer, or in the Realtek Control Panel, depending on which your system uses) to record from “Line In”.

There is more information about using the Windows Mixer here:

If your system uses a custom Realtek user interface, then you will need to hunt around in its settings to find where to change this. From other users on this issue, the setting can be difficult to find, but it is there (somewhere).

Thanks for the swift reply.

I must be being really dumb as this isnt working for me.

First up i can record my guitar no problem on the line in however not using the ‘line in’ on audacity it only records with the ‘mono mixer’ or ‘stereo mixer’ option selected. Possibly my problem lies there as well.

Anyway thanks for the help so far i’ll keep plugging away and see if i cant get it to work somehow.

Haha !!!

Cracked it. I was actually using my aux line in 2 , i didnt realise. Now all works well.