Compiling troubles on Mint Linux

Hi all,

I’m having some trouble compiling Audacity on Mint Linux. It’s giving me an error when I run ./configure which says that it cannot locate the wxWidgets library. I’ve successfully built and installed wxWidgets 2.8 (I understand that it doesn’t yet work with 3.0, correct?) and upon installation, it suggests that you may have to modify the LD_LIBRARY_PATH variable. I’ve tried doing a Google search for how to do this (I’m fairly new at Linux, in general), but all the forum posts I found were unhelpful. Any insight or advice would be much appreciated!

When WxWidgets is installed, it installs a load of libraries that will be used when building a WxWidgets application (such as Audacity). For these libraries to be available, they need to be known to the system - that’s what ldconfig does - it configures the bindings to the new libraries. Usually, rebooting the computer will do the same job.

I’ve recently built Audacity on Linux Mint 16 Cinnamon, and there is actually an easier way to do this, but as you have got so far, try rebooting the computer and then have another go at configuring Audacity.

If you get the same error, uninstall WxWidgets (“sudo make uninstall” from within the same folder as you previously ran “install” should do it), then call back here.
If you have problems uninstalling WxWidgets, please describe exactly what happened.

Hi Steve,

I appreciate the help. I restarted the computer, but it gave the same error when running ./configure. I was able to uninstall wxWidgets without issue.


Try these instructions:

Note that source code repositories need to be enabled (as it says in the note below the steps 1 to 8).

When you run step 3 (sudo apt-get build-dep audacity ) watch to see that it succeeds without error. If there is an error, make a note of it and post the error message here.
Don’t bother trying to continue if step 3 fails.

After step 7 (make), try running:


Audacity should launch. If it does, then just run step 8 (sudo make install) and you’re done.

The steps about “sudo apt-get install autoreconf” are not currently required.

Thanks again for the advice. It was still failing on the ./configure part of those commands with the same error. I was able to get past it though, by including usr/local in the LD_LIBRARY_PATH environment variable. It successfully ran the configure command. Now, though, when I make the project, it fails with the following message:

Any idea of what could be going on here? It seems like perhaps I have a bad wxWidgets install? I’m really not sure…

Thanks again for all the help, I really appreciate it :smiley:

Is this still a problem?

As I understand it, the steps at use the system wxWidgets - but it looks like you are still using or trying to find a local build of widgets, although you uninstalled it. Perhaps this is because you included usr/local in the LD_LIBRARY_PATH?

The initial error you got seems to be because you configured a unicode version of Audacity but built ansi release version of widgets. What does this return?

wx-config --list

If it still returns ansi release then you might be able to build Audacity with ./configure --disable-unicode, or go back to building widgets locally but configure it with --enable-unicode.