Compiling FileDialog.h error wx/defs.h No such file [SOLVED]

Debian Version 7.6 (wheezy) 64 bits, Noyau Linux 3.2.0-4-amd64, GNOME 3.4.2
I follow Example compiling the latest Audacity source code
Steps 1 to 4 ok…
5. Download the source code:
svn checkout audacity-read-only
Steps 6 to 9 ok…
10. For Debian Wheezy, configure with:
./configure --disable-dynamic-loading
11. Build the application:
make => Error as summarized under subject, see

pierre@debian-Sony-VGN-NS21Z:~/audacity-read-only$ make
Making all in help
make[1]: entrant dans le répertoire « /home/pierre/audacity-read-only/help »
make[1]: Rien à faire pour « all ».
make[1]: quittant le répertoire « /home/pierre/audacity-read-only/help »
Making all in images
make[1]: entrant dans le répertoire « /home/pierre/audacity-read-only/images »
make[1]: Rien à faire pour « all ».
make[1]: quittant le répertoire « /home/pierre/audacity-read-only/images »
Making all in lib-src
make[1]: entrant dans le répertoire « /home/pierre/audacity-read-only/lib-src »
Making all in FileDialog
make[2]: entrant dans le répertoire « /home/pierre/audacity-read-only/lib-src/FileDialog »
make  all-am
make[3]: entrant dans le répertoire « /home/pierre/audacity-read-only/lib-src/FileDialog »
/bin/bash ./libtool  --tag=CXX   --mode=compile g++ -DHAVE_CONFIG_H -I.  -I/usr/local/lib/wx/include/gtk2-unicode-release-2.8 -I/usr/local/include/wx-2.8 -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D__WXGTK__ -pthread -pthread -I/usr/include/gtk-2.0 -I/usr/lib/x86_64-linux-gnu/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/gio-unix-2.0/ -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12     -g -O2 -MT libFileDialog_la-FileDialog.lo -MD -MP -MF .deps/libFileDialog_la-FileDialog.Tpo -c -o libFileDialog_la-FileDialog.lo `test -f 'FileDialog.cpp' || echo './'`FileDialog.cpp
libtool: compile:  g++ -DHAVE_CONFIG_H -I. -I/usr/local/lib/wx/include/gtk2-unicode-release-2.8 -I/usr/local/include/wx-2.8 -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D__WXGTK__ -pthread -pthread -I/usr/include/gtk-2.0 -I/usr/lib/x86_64-linux-gnu/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/gio-unix-2.0/ -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -g -O2 -MT libFileDialog_la-FileDialog.lo -MD -MP -MF .deps/libFileDialog_la-FileDialog.Tpo -c FileDialog.cpp -o libFileDialog_la-FileDialog.o
In file included from FileDialog.cpp:17:0:
FileDialog.h:20:21: fatal error: wx/defs.h: No such file or directory
compilation terminated.
make[3]: *** [libFileDialog_la-FileDialog.lo] Erreur 1
make[3]: quittant le répertoire « /home/pierre/audacity-read-only/lib-src/FileDialog »
make[2]: *** [all] Erreur 2
make[2]: quittant le répertoire « /home/pierre/audacity-read-only/lib-src/FileDialog »
make[1]: *** [all-recursive] Erreur 1
make[1]: quittant le répertoire « /home/pierre/audacity-read-only/lib-src »
make: *** [all-recursive] Erreur 1

How to fix ?
Thanks for your help.

Which version of wxWidgets are you using and how did you install it?

Actually :

pierre@debian-Sony-VGN-NS21Z:~$ wx-config --version

I did installl wxWidgets during some previous attempt to get Audacity 2.0.5 by following Example long steps in
Attempt failed. Furthermore issue was lauching FileZilla idem Audacity leading to error like :

audacity: relocation error: audacity: symbol _ZN12wxStringBase8InitWithEPKwmm, version WXU_2.8 not defined in file with link time reference

so I did sudo make uninstall in ~/Téléchargements/wxGTK-2.8.12.
Actually, I would like to get the latest Audacity version running on my Wheezy.

Probably Audacity is still looking for the locally installed widgets. You could try a more thorough removal of that. Have you tried

sudo ldconfig

to update the system for the removal?

You can always configure Audacity to point to a specific wxGTK such as

WX_CONFIG=/usr/local/bin/wx-config ./configure

So you could rebuild your local wxGTK and point to that if you cannot cleanly remove it.

This command:

make -n install

shows you the steps to install. Reversing those steps should give you a clean uninstallation.


So I could rebuild local wxGTK and point to that, because I could not cleanly remove it.
Here are the last steps leading to success :

cd ~/Téléchargements/wxGTK-2.8.12
./configure --enable-unicode
sudo make install
sudo ldconfig
wx-config --version => 2.8.12
cd ~/audacity-read-only
WX_CONFIG=/usr/local/bin/wx-config ./configure --disable-dynamic-loading
sudo make install

For some who want to read my painful steps, read
Audacity205.txt (5.73 KB)
Thanks a lot for your help. Pierre.
[Moderator note: Document is partly in French]