Compiles and Runs but not on another computer

I have compiled the latest windows master build on VS2013 with wxwidgets 3.1.1 and ASIO included. All exactly as per compile.txt and its works correctly. However if I copy the “release” directory to any other windows 10 computer it fails to run with
“unhandled unknown exception, terminating the program”
These machines are all on windows 10 pro and fully up to date and one of them is the same processor family ( core-I7 ) as the originating machine. They all use the same anti-virus software. I’ve also tried builds from other branches. If I remove the settings folder in %appdata% I do get the introductory dialogue about file associations before the error occurs. If I use the standard download of Audacity it runs correctly ( but I really need the ASIO support).

I would be grateful for any help or suggestions.


Have you added the wxWidgets DLLs to the ZIP / installer?
To make a build that can be installed on other computers, this page may be useful:
Please note that due to license terms, ASIO builds must not be distributed - own use only.

Thanks Steve, that’s a very useful link and I’ll certainly check the relevant dlls to see if there is something missing or incompatible. I’m pretty sure the wxWidgets ones are correct. Rest assured this is only for my own use, my main objective is to be able to record at 384KHz 32 bit fp directly into Audacity. If all else fails I will try to run a remote debug session from VC on the build machine to the target one.

Having tried every variation I could think of I finally pulled back to the released version 2.2 and removed the ASIO extras. This worked on all three computers so the problem is definitely ASIO related. It remains baffling that I can use the ASIO devices (RME babyface and RME ads-2) on the machine used for compilation and audacity works correctly. Its only when I copy it to the other machines that it fails.

I’m not able to test s I’m not on Windows, but my guess is that there are some ASIO DLLs that need to be installed / available, which are available on the build machine because you installed the ASIO SDK, but not one the other machines.

The fix for this was extremely simple. I removed the registry entry for the Realtek ASIO driver in localmachine>software>wow6432node>asio and suddenly every version I had previously tried worked again. I stumbled across this reading through the ASIO help pdf, a shot in the dark really. Of course I have no idea why it caused the crash This driver was introduced with the Realtek HD audio device drivers which seem to be present on almost every windows installation even if not used. For the record the driver version was and windows says that its the correct version even though there are later versions on other machines ( different intel chipsets?)