Compile of SVN Audacity fails on Fedora 23 [SOLVED]

I’m currently attempting to compile the SVN version of Audacity on Fedora 23, x64.

As usual, all directions described on and have been followed.

Additional information about my setup:

  • I have ffmpeg and a bunch of additional libs scattered around /home/etna/Applications/GIMP/depends/lib and /home/etna/Downloads/avdepends/lib

My ./configure is as follows:

CFLAGS='-fPIC' LDFLAGS="-L/home/etna/Downloads/avdepends/lib:/home/etna/Applications/GIMP/depends/lib" CPPFLAGS="-I/home/etna/Downloads/avdepends/include:/home/etna/Applications/GIMP/depends/include" PKG_CONFIG_PATH=/home/etna/Downloads/avdepends/lib/pkgconfig:/home/etna/Applications/GIMP/depends/lib/pkgconfig:$PKG_CONFIG_PATH ./configure --prefix=/home/etna/Applications/Audacity --with-libvorbis --with-libflac --with-ffmpeg=system --with-lame --with-libid3tag --with-libmad --with-libsndfile=system

When running make, the build fails and claims that sndfile.h cannot be found even though it located at /home/etna/Downloads/avdepends/include as defined in the ./configure step, so i copied the .h files temporally to /usr/include and the build proceeded from there. However, it later fails with multiple errors about ffmpeg.h having conflicting definitions for a number of items. as shown in the pastebin link

Any assistance will be greatly appreciated

The FFmpeg library can be a pain as there are frequently big changes between versions that break things when trying to link.
I’d suggest that you first try to build without FFmpeg (something like .configure --without-ffmpeg but check in .configure -h).
If that builds successfully, do

make distclean

then try configure with:


Thanks for replying. Building with --without-ffmpeg returned another set of errors at the linking stage:

It looks like another dependency is missing, but I can’t figure out what it is?

Doh, just noticed that you said “SVN version”.
Audacity no longer uses SVN - that’s the old, unmaintained Sourceforge repository. The current Audacity code is on GitHub, and it requires WxGTK 3.0 (preferably 3.0.2).

Trashed the SVN copy and cloned the GitHub version.

The Git version still fails with the same ffmpeg conflicts when built normally, but succeeded with --disable-dynamic-loading. I guess the issue is solved?

Excellent, that was quick - you must have a faster machine than me :wink:
I’m not sure why, but Audacity is a lot less fussy about the FFmpeg build when using --disable-dynamic-loading. It’s a workaround that Ubuntu uses on their repository builds. Audacity may eventually move from using FFmpeg to using GStreamer which will hopefully make this issue a thing of the past.

I’ll mark this topic as “solved”.