Commentary audio not splitting correctly in audacity

Hello , I’m Justice and I need help badly.
I have a windows 10 , I use Audacity 2.1.1!
I want to record and upload youtube videos but I cannot because when I record me and my friends playing games the audio doesn’t split correctly. I bought an audio Splitter , this Splitter > < Well anyways the promise was that when I am playing I can use that to record and when I’m recording in audacity the splitter will split the audio into a 2 stereo recording where my voice is on one track of the 2 stereo recording and my friend’s voice’s were on the other track. This was the video I was following and the goal I was trying to achieve > < It is VERY important that my voice is on a separate track , so that I can edit it without ruining the rest of the sounds , but instead of separating the audio and putting my voice on one and the rest of the sound on the other track it just records all the sounds on both tracks. The tracks are the same for me , they have both my voice and my friend’s voices on them together but for the guy in the video his tracks were able to get his voice isolated on a separate track. I took a screenshot of my problem. Note that I copied all of the guy’s settings and still my tracks didn’t split the way his did > < I would like to know if anybody can help me get my audio to record the way that the guy in the video’s audio recorded , with his voice on one track and all the other sounds on the other. I need this so badly if I want to fulfill my dreams of becoming a youtuber , thank you so much for reading.
Looking forward to anyone’s help! :smiley:

At 1 minute 26 seconds
“…I know that some of your computers might have a mono mic input…”

Well , are there anyways to check if my laptop only records in mono? And also if my laptop does only record in mono is there anything I can buy to get my sound to record like the guy in the video’s did?

Have a look in the recording settings in the Windows Sound Control Panel. Are you able to set the microphone input to “2 channel stereo”?

Ok , so when I first open up the sound control panel I see 2 recording options , Microphone and Stereo mix. I clicked on properties of the Microphone (it’s internal) but it didn’t give me any option of changing the input. It just had different tabs at the top like General , Listen , Levels and so on. I couldn’t find anything about the input but when I went the advanced tab it showed that the default format was 2 channel , 16 bit , 48000 Hz (DVD quality). So I’m not sure if I missed something or clicked something wrong but I think that my microphone is recording in 2 channels. If I missed something then I’m not quite sure how to navigate where you want me to go.

Did you enable “Show disconnected devices” and “Show disabled devices”?

The way that I would test if the input is mono or stereo is to do koz’s “touch test”
Do you have a suitable lead to do that?

Everything is showing , and my laptop doesn’t have 3 sound slots only 2. And that’s mic and headphones , so I am convinced my laptop only records in mono. Now that that is established what can I buy to fix the problem and get audacity to record my sound like the guy in the videos. Names or links would be helpful.

Does your computer have an internal mic as you suggested? If so, then from your picture you may not have the external mic available in Windows. Did you do the right-click in empty space in Windows Sound, “Show Disabled Devices” and “Show Disconnected Devices”?

If you have a stereo TRS to RCA cable you can use


The mic I was referring to is internal. And yes all the devices were showing ,disconnected and disabled and all.

Then do you have the internal and external mic tied up as one jack? Look in the Realtek Control panel. There may be something there.

This is recommended on the page for the splitter, as alternative to the UCA. That appears to be a “stereo mic input” but may or may not be as good as the UCA. The UCA might give too quiet a result as that is a proper line level input.


When I plug in the splitter it doesn’t come up as an external mic. So I have no external mic just the internal one.

As I said, if you have Realtek set to “Tie up same type of input jacks” (or similar) then the splitter will not show separately.

But it won’t hurt to buy a USB interface to plug the splitter into. You may get better sound that way,


I don’t see that anywhere. I’m very confused.

If you have it, it’s In Realtek HD Audio Manager, Device > Advanced settings or the gear icon top right.