Collapsed track only shows half the wave

When collapsing a track, only half the wave appears in the bottom of the track. This makes it very difficult at times to see when there is audio in a collapsed track. Previously, when a track was collapsed, the waveform would scale down to the collapsed track height and remain centered in the track.

Audacity 2.2.2 on Windows 10

That appears to be a bug. I’ll log it on the bug tracker.
I note that if you manually drag the track height to minimum size, the waveform is correctly centred, so perhaps that may provide a workaround until the bug is fixed.

Now logged on the bug tracker.

This is a deliberate feature that was introduced in 2.2.2 as a way of showing more detail, where we now only shows the top half of the waveform in a collapsed track.

You can do the same on non-collapsed tracks by using the right-click context menu in the Vertical Ruler and selecting “Half Wave” - and note that in that menu there is also a reset command to go back to normal view.

So this is not a bug.

I note that we do not appear to have documented this in the Manual - an oversight I’m thinking


Thank you for the replies. My projects typically include 6 vocal tracks for a 90-120 minute duration. When editing on a laptop, I find it faster to quickly collapse the tracks of people not speaking so I can see all tracks onscreen and tell who is speaking (or coughing or bumping their mic) and who is not. (Fit to screen height doesn’t give enough resolution for precise editing.) For me, it is much harder to see that there is audio activity on a collapsed track, especially if it is short or at a low level. So I find myself in the “I wish it worked the old way” camp. Ironic because I’m usually critical of people who can’t “get over it.”

I’ve also noticed that if I was zoomed in on, say the lower half of the waveform before collapsing the track (I may be more interested in the lower half if the waveform is asymmetric), in 2.2.1 and earlier I could collapse the track and my view of the lower half would be restored when I restore the the track to normal height. That no longer happens. Expanding the collapsed track now resets the view to “normal” (full +/- 1) zoom level. This makes the collapse feature less useful for me, which is a shame because collapsing tracks was so useful with multi-track projects.

We are discussing how to deal with this - there are a couple of approaches on the table

  1. add a preference to set choice for half-wave of full wave in collapsed tracks, or
  2. preserve the wave type full or half when the user collapses the track

Interestingly I discovered that even with a collapsed track you can still use the right click in the two little whit rectangles (the collapsed remnants od the Vertical Scale) to access the context menu.

Which means that if you right click there now - and then select Zoom Reset you will get your full-height waves displayed in the collapsed track.


OK if you only have a couple of tracks, but the main purpose of collapsing tracks is to improve usability when you have a lot of tracks. Having to manually reset the zoom, track by track, for a 20+ track project is a significant inconvenience.

Yes indeed - but this is just a temporary workaround.

And I see that the developer involved has already been working on a fix: Bug 1860 - Enh: Add preference to disable half-wave view on collapse. · audacity/audacity@2db691d · GitHub

and he’s opted for the new preference route.


Yea! The team doesn’t fool around when it comes to getting things done, it seems. Thank you!

hahaha - don’t get too used to it - it’s not always like that :wink: :sunglasses:


And I’ve tested this today on my Mac and it works just fine and dandy.
Also you’ll probably be please to know that the default for the half-size is “off” - so by default you get both halves of the waveform in a collapsed track.


Anyone know in what version this default started? Not interested in bleeding-edge 2.3 (I use it for work, not play, so if it’s higher than front-page I don’t want it), and really despise the half wave view of collapsed tracks (all of the tracks I’m not working with at the moment are collapsed). I really want to back-step to a version that doesn’t default to this.

This is why I should know better than to upgrade open-source that ain’t broken…

Stick with the released 2.2.2 for now and go to Edit > Preferences choose the Tracks tab then and uncheck Use half-wave display when collapsed - hey presto: you get full collapsed waves …

And BTW the upcoming 2.3.0 is pretty near to release now and not much is different just some cool new stuff added.