clipping problem with soundflower

I don’t know if it has to do with soundflower but I’ve never had the problem otherwise. I’ve brought it down to -18db and it clips with the same duration of silent spaces.

Maybe you should to tell us a ton more about what you’re doing?

Which OS-X? Which Audacity (all three numbers). Where is the show coming from? What’s the goal?


Reduce “Audio to buffer” at Audacity, Preferences…, “Recording” section.

Give us all the details Koz requests if that doesn’t help.


OSX 10.9.5
audacity 2.1.0
the problem is not with soundflower it’s contained to audacity.
I changed audio to buffer at 66 and the problem’s gone, do you recommend I change the latency correction too? Before I saw your replies and before I changed the buffer I messed around with the compressor and it created a slightly staccato metronome sound, which is now gone but it would put me at ease to know where the default settings are or whether there is a way to return all settings to default.

more importantly, I use the program for dialogue from DPA 4080 cardioid lavaliers used on location, and I when I pop those files in audacity I hope to hear it the way it was recorded without any modifications before I edit. So the goal is to maintain the original integrity of those files and move them in and out of audacity without modification. I’m using a Marantz 661 recorder and don’t know if I should export them as Microsoft WAVs or NIST Sphere WAVs: they’re 24-bit PCM at 96k, sometimes 44.1k.

change the latency correction too?

Latency Correction is a post-production setting having to do with matching music tracks during overdubbing/sound-on-sound. It has nothing to do with straight recording or playback.

I would expect Audacity to play already recorded works perfectly with no noise. The noise comes from the juggling act the recording side has to do to maintain a live, real-time, stable data stream. The computer can’t say, “Hold that violin note for a second while I do some housekeeping.” Everything is right now and computers aren’t fond of doing that.

in and out of audacity without modification.

That’s not normal. Audacity adds a tiny dither signal to works to make up for the bit-depth conversions it does internally. If you make no changes at all to the work, you can turn dithering off. Audacity > Preferences > Quality. If you make so much as a slight volume change, you should leave dithering on.


I’ve read your post three times now and I still don’t understand what’s happening…

You “pop” the files into Audacity?

  • Did you use the “import” function, or did you drop the files onto an open Audacity window or on the program’s icon?

What could be happening is that your 24 bit files are seen by Audacity as 16 bit. That could explain the clipping.

I changed audio to buffer at 66 and the problem’s gone

This shouldn’t be related.

  • Do you have ffmpeg and/or lame installed? If yes, which version?

Don’t use NIST Sphere WAV, unless you need to put your audio in one of the scientific audio databases that still use this format. It’s almost the same as a normal wav, but some audio programs crash while reading the headers. It also allows for (lossless and lossy) compression formats that are only used in the scientific world.

If meeded, sox can convert NIST Sphere WAV to normal wav. You’ll find sox here:

It could be a rare case of Flash card corruption, but that would really surprise me…

It is exactly related, thought it isn’t distortion due to excess volume:
Audacity Manual.


Thx, Gale. Forgot about that.

But still, I can grok dropouts or clicks, but clipping?