Clipboard (cmd+x) corrupted when pasting into new session

I searched the forums and couldn’t find an instance such as mine. And sorry if this post appears twice. I thought I’d posted it successfully the first time, but apparently I didn’t. So here’s the second attempt…

System details:
MacBook Pro mid-2009 (OSX 10.7.5), SSD for system disk, 8GB RAM
Audacity 2.0.3 installed from dmg

Here’s what’s happening when I do the following:

  1. open a wave file
  2. place cursor anywhere after beginning of file (I’ve been selecting towards the end)
  3. press cmd+k (waveform is selected from cursor location to end of file)
  4. press cmd+x (selected area is cut)
  5. press cmd+n (new session is created)
  6. press cmd+v (cut selection is pasted into new session)
  7. return to original [named] waveform
  8. export waveform, overwriting original (click YES at warning, and OK at metadata prompts)
  9. close waveform
  10. playback waveform created in new session

Actual results: ~1 second of clipboard material is heard followed by a looping of the first 1 or 2 seconds of the beginning of the original waveform to the duration of the file. Waveform view still appears as it did when clipboard material was pasted.

Expected results: actual clipboard material plays back in its entirety.

Is this happening to anyone else?

Moderator note: please don’t doble post. We’re sorry but all new posts have had to be moderated in our attempts to keep this a clean and sane, family friendly corner of cyberspace - by screening out spammers and trolls. I removed the duplicate post for you.

Mod: d’oh! Sorry about that. Brain fart. Won’t happen again. Promise. (This draft was the better version anyhow as it includes the Audacity version #)

Thanks for the report.

I assume you meant SHIFT + K, or you have modified Audacity shortcuts?

I don’t think it matters but it was not clear if this was File > Close without saving changes, or by pressing the [X] on the track.

Tested on Windows, but it does seem to be a problem if you don’t copy the audio into the project, and happens as soon as as you export (you don’t need to close the original window where the file was imported or close its track).

Audacity should explicitly be reading the project from the original file (retained and renamed with “-old1” suffix) rather than the file you overwrote. You can verify this by undoing the cut in the original project window (the end of the audio still plays correctly). However even the Undo does nothing for the pasted audio in the new project window. This will need looking at.

To avoid the problem go to the Import / Export Preferences, enable “Make a copy of uncompressed audio” then click OK. If you have the warning about uncompressed files set to show when you import WAV or AIFF files, be sure not to change the setting to “read directly”.


I assume you meant SHIFT + K, or you have modified Audacity shortcuts?

Ermm, yes, I meant SHIFT+K, not CMD+K.

To avoid the problem go to the Import / Export Preferences, enable “Make a copy of uncompressed audio” then click OK.

This seems to work. Thanks for your help on this!

If you look at File > Check Dependencies in the project that has the pasted audio, the dependency is still on the original file name, not the renamed -old1 file that has the original audio.

To avoid the issue, the we would have to change the dependency to the -old1 file after overwriting the original, for all open projects that used that file.

Of course if other closed projects depend on that file and you modify the file subsequently, there is nothing sensible Audacity can do about that.


And thanks for the apology for the double post, much appreciated. :slight_smile:

Don’t worry about it, you’re not the first and I’m sure you won’t be the last to wonder where their post went while it sat in the moderation queue for a while. It doesn’t normally take too long as we have forum elves living in different time zones around the world (and often keeping strange on-line hours).