Clicky playback to external interface [SOLVED]


I have installed the latest version of Audacity on my iMac. I use OSX Mavericks as operating system. For sound recordings I use the external audio interface Edirol FA-66, which you have to connect on the computer by using a FireWire 400 cable.

(The audio-interface runs with Core Audio, which means you cannot install drivers on OSX.)

When I run Audacity and I use my audio interface as the output for sound I encounter problems: I hear clipping. The clipping is not in the sound-files. Also when I use the FA-66 as input the recordings are fine (which I can listen back through other applications like iTunes). The recordings made by Audacity sound even better than by Logic Pro X: that’s why I want to continue using Audacity. Also I am more familiar with Audacity than with Logic Pro X

I found out that the phenomenon ‚clipping’ occurs a lot less and sometimes it doesn’t occur at all when I run the application Jack Pilot together with Audacity. (I don’t know what the applications Jack or Jack Pilot are; someone gave me the advise to try it). But mostly the clipping phenomenon is still present.

I suspect the problem has something to do with the samplerate-output, though I make sure the desired samplerate (96 kHz) is selected the same under Audacity.

Does anyone know how I can solve this problem?

Thanks! Michael

Are you connecting with FireWire 400 or FireWire 800? I see it has the option.

You have the limiter off, right?

Does it still do it if you try a recording and playback at 44100 (Audio CD rate), instead of 96000?


Sounds like your Edirol is getting the signal twice. Could it be Jack is routing the audio twice?

I don’t think this is a Firewire problem, cause that usually surfaces as in interfaces not working, clicks or dropouts. And I know the Edirol FA66 to work with a recent Mac with FW800 ports and Mavericks, as I’ve used one.

Please give us all three version numbers of Audacity from Audacity > About Audacity… , not just say it’s the “latest version”.

If the problem could be described as “clicking”, have you tried what would be the most obvious solution - reducing “Audio to buffer” in Audacity’s Recording Preferences? That setting affects playback too. The fact the problem is lessened with JACK also suggests that latency/buffering is the cause. Take the buffer setting down to 0 milliseconds, then if the audio does not play, increase buffer by 10 millisecond increments until it does play.


Sorry for my late respons.

Thank you for your advise. I reduced the “Audio to buffer” from 100 milliseconds (standard) to 10 and now it works perfectly! :sunglasses: (Setting it to zero doesn’t make it play audio)