Clicks after normalizing

Once I’m done recording a chapter I save an original raw file. Then I listen, clean-up any obvious noise/clicks/do-overs in the track. Then I select a section for a noise profile and apply it to the entire track. Then I apply normalization. Once I apply the normalization I go back over the track, one more listen for good measure. When I go through this final listen I always seem to find quite a few clicks that have be made louder and need to be removed.

I have two questions:

1 Would this still happen if I normalized and then applied the noise floor profile?
2 Is there a way to remove all the clicks at once from the track?

Thank you for any help!

Is there a way to remove all the clicks at once from the track?

How about we try to get rid of the clicks during recording? Creating a forest of clicks in a voice track is not normal (unless you’re like me and create them yourself during reading).

So take it back to the beginning. Which microphone, which connection and which three-number Audacity?


Create and post a forum test.


Hello Jack. There are many things that will cause “Pops & Clicks”, also known as “Gapping” in the audio world. It could be as simple as having your system on the same circuit as your microwave or dishwasher. From your question and not knowing what your system setup is, I would suggest you trouble shoot your CPU usage first. This is one of the main culprits and is very easy to do. I switched to a dedicated system used for audio only to elevate this problem. It has 8 programs on it. Windows 8.2, Anti-virus, Firefox and five audio programs. Keep your system well maintained by using defrag and performance enhanced software on a weekly basis and do the following before you fire up Audacity.

  1. Reboot your system.

  2. Disable any programs running in the background not needed to operate your computer system. This could be anything from virus software to automatic updates. This will help reduce the load on your CPU.

  3. When you run Audacity, make sure that is the only program running outside of your operating system. When you apply effects and depending on what type of setup you have, you may want to try running only one at a time. Each effect you add will require more CPU usage.

This advice goes for if you are recording directly into Audacity as well. You would want to follow this same procedure. If you are recording and your fan is kicking on and your automatic update is running while your anti virus software is checking things in the background, you can see how this could turn into a big mess. When this happens you open the door for pops and clicks. Again without knowing what your system is, this is where I would start.

To answer your 2nd question, you can do everything right as far as getting the signal in, only to have it go bad during mixdown and as you have noticed, you will never know till you do your final listen. This is a free & easy way to rule out overloading your CPU.

  1. Reboot your system.

All that but in addition, if you suspect something seriously wacky happening, a clean Windows reboot is good. Shift-Shutdown will do that. That might take longer than you’re used to. That’s normal. Windows is really starting from scratch.