Click Track

It seems no matter how many guitar takes I do the rhythm is always slightly off from the click track when played back. When I record live I know i am playing it in relatively perfect rhythm (and I have never had many problems with playing in rhythm to a click track in the past) but when i take a listen back it is always off. Any tips to help me?

I messed around in Edit>Preference but have had no luck. It might have something to do with the Software Playthrough (play new track while recording it) check box option. I had it checked previously and thats when is the problem was really noticeable, I recently unchecked it and it seems to work a little bit better but still not good enough. I have version 1.2.6 of Audacity. Thanks a bunch.

Software Playthrough and “Play other tracks while recording new one” are two completely different things. You should NOT have Software Playthrough on. But you NEED to have “Play other tracks…” turned on in order to make Multi-track recordings.

But that might not completely fix the problem. You’ve got one of two possible problems: You either have clock drift where the record will drift further out of time as it gets longer, or you might just have recording latency where the “offness” of the track is constant during the entire track.

Clock drift is generally caused by poor hardware. You can try recording at a different sample rate and it might work better (try 48KHz instead of 44.1KHz and see if it’s better). If that’s not working (or if it’s annoying), buy new hardware. Motherboard sound cards seem to suffer from this more often than they should.

Latency can easily be fixed by using the Time Shift Tool.

I believe it might be “offness” because while it is out of rhythm time with the click track it is rhythm with itself. Any tips?

Also does “real time sample rate recorder” or “high quality sample rate converted” have anything to do with it? I have them both set to “Fast Sinc Interpolation”.
I also have “Real-time Dither” set to none and “High-quality Dither” set to Triangle. Could changing any of these setting help out?

I find it handy to give myself 2-4 bars of the click track before i start recording guitar.The bar before i start playing i whack a muted string (or all six) in time with the click track. that way it produces 4 distinct peaks (if its a 4/4 song) that can later be alligned to the click track with the time shift tool.

get what i mean? so it goes

Click, Click, Click, Click,
Click, Click, Click, Click,
whack, whack, whack, whack, (you on guitar in time with the click)
Click, Click, Click, Click,
then start playing from the next bar, you can delete the whacks later with the silence option but only get rid of it after youve recorded all your track, use this same method for vocals, bass, drums etc, that way you can line everything up nice.

hope that helps, i only generally have this problem when im recording my 6-7th track so maybe you need to upgrade some hardware . being able to line up tracks is usefull but its pretty hard to get it exact so avoiding the problem is better.

good luck