Click Track Issue


My friend was noticing he couldn’t get the click track to a decimal count, e.g. 146.5 bpm
He was trying to sync a click track that I did at 146.5 but couldn’t match it.
Can it even be done? :wink:

No, the BPM is an integer value (whole numbers).

One way round it would be to make one bar at 146 bmp and a second bar at 147 bpm, then use “Repeat” (about half way down the effects menu) to make the number of bars that you need.

This will probably be close enough as there will be no beat more than 4 milliseconds out. If not, then he could work out how much extra space (in samples) needs to be added between each beat to make a 147 bpm click track stretch to 146.5 and generate that amount of silence manually between the beats (don’t forget the last beat). Again this would only need to be done for one bar, then the Repeat effect can be used.

Yep, sure that’s what I’d do or change the speed etc. But my friend isn’t very computer savvy and has asked me why Audacity cannot do this on it’s own.

Since bpm is in whole numbers, is there still a way to do it. I told him to speed the bpm up to 146.5 x2. At least he’s got the right tempo, even if it is double time. That does give an option, but it’s kind of a band-aid solution.

For me to get around it, I have that capabilty and have all sorts of tricks to get around this as you can see.
But I was hoping this type of option for Audacity could give those who just want to match a beat easier.

(It’s not fun getting passed back an mp3 with offsetting clicktracks hammering away because he couldn’t sync them:D )

If there’s anything what you can do, it would be appreciated

Here’s a custom version that should support fractional bpm.
If you find it useful (and it works OK), post a message on the “Feature Requests” board and it may get included in future Audacity releases.

Extract the contents of the attached zip file into the Audacity plug-ins folder. When Audacity is restarted it should appear in the Generate menu listed as “Click Track (custom)”. (3.61 KB)