Click removal

I’m using 2.0.0 with Ubuntu 12.04

When I try to remove a click I select the passage with the click in it and choose ‘click removal’ from the effects menu. If I select ‘preview’ the passage plays fine with no click. However, if I select ‘OK’ nothing seems to happen and the click is not removed. Am I doing something wrong, or is this a bug?

  • Richard.

Sorry, I should have added that it was installed from the repo. FWIW, I’m using the Mate desktop.

  • Richard

I don’t see anything obvious that you are doing wrong, but on the other hand, if clicks are removed on preview then they should also be removed when you apply the effect. I’m not aware of any bugs in this area.

Could you perhaps post a short audio sample in WAV or FLAC format (just a few seconds will be fine, but not MP3) and post exactly what settings you are using so that I can try and reproduce the problem.

Here are a few seconds in an attached file (click.flac).

The settings I used were the default ones, namely:
Threshold 200
Max spike 20

File menu > Import > Audio
Select “click.flac”
Click “OK”
The file is imported.

Double click on the track to select it.
The track is now highlighted.

Press Spacebar to play
I hear a big click near the middle of the track. I very much doubt that click removal will make any impact on that click at all.

Effect > Click removal
Threshold 200
Max spike 20
Click “Preview”

I don’t hear any difference. The click is still very much there. As I expected that click is far too big for Click Removal to recognise as a click and not as part of the music.

I would use “Pop Mute” on this with fairly strong settings:
Threshold -12
Mute level -60
Look ahead 30
Release time 500

Pop mute:
Installation instructions:
Please read the “Help” that is included in the plug-in.

Let me know how you get on.

I’m curious why the click appeared to be removed when you previewed it.
How long is your preview?

Thanks. That was very helpful.

I applied pop mute to a selection in the original file, and that reduced it to a much smaller, higher frequency, click. I then applied click removal and that worked fine and removed the noise altogether.

Strangely, I then applied pop mute to the click file that I posted (which was just a similar selection from the original) and that removed the sound entirely in one go. That seems odd to me.

The preview on the original file was about the same length as the file I posted. Maybe a few seconds longer, but probably not more than twice the length.

  • Richard.