Chris's Dynamic Compressor Won't Enable - Audacity 2.3.0

I am trying to ENABLE Chris’s Dynamic Compressor, but it won’t stay enabled.

Effect/Add Remove/Enable. After doing that the plugin doesn’t enable and just goes back to be disabled.

Plugin was working fine until I upgraded to 2.3.0.

Running 2.3.0 on Mojave 10.14.

Any thoughts?

Do you have a lot of external plugins enabled? The reason I ask is that one thing we can try is resetting Audacity’s plugin registry. You’ll have to re-enable your plugins after the reset.

To do that, go to:
~/Library/Application Support/audacity

In that folder, delete the files:

Start Audacity and see if you can enable “Compress &dynamics 1.2.6”

– Bill


Tried that. The plugin now shoes as New versus Disabled. I Enable it hit OK, it appears to be processing, then I check to see if it worked and it didn’t. It doesn’t get added to the menu and goes back as a New plugin.

I have tried this several times with no luck. I am also seeing the “Audacity quit unexpectedly” program crash window come up from time to time when I try to enable this plugin. I have added other plugins without a problem, but this one will not work since the upgrade to 2.3.0.

Hmmmm … this is all very strange. I’m running Audacity 2.3.0 on macOS 10.14 and it enables, runs fine, and Audacity doesn’t crash.

Two things:

  1. where did you get the file? Does it say version 1.2.6 in the Enable Plugins dialog?
  2. we could reset all Audacity preferences:
    go to ~/Library/Application Support/audacity and delete the file audacity.cfg.

– Bill

I have tried resetting all Audacity preferences and it doesn’t help.

The plugin shows simply as “compress” in the dialog.

I got the file here:

That’s the right version of the plugin, but the installation instructions there are out of date.

The file should be installed in ~/Libarary/Application Support/audacity/Plug-Ins

Is that where it is?

– Bill

Thanks for the help Bill.

Yes, that is where it was located.

After a lot of troubleshooting, I totally removed every Audacity folder and file and did a complete reinstall. That fixed it.

Could you tell us what “every Audacity folder and file” means? Did you have an “Audacity” folder inside your Applications folder, and a “Plug-ins” folder inside that? Did the problem go away when you deleted that “Audacity” folder?

I’m trying to get a read on this so we can perhaps help others that have a similar problem.

– Bill

I got it to work as follows. I using Mac OS X 10.14 and Audacity 2.3.1.

After installing Audacity in the Applications folder, have a look in Applications. You’ll see “Audacity” but it doesn’t look like a folder. Right mouse click on the Audacity app icon. Choose “Show Package Contents.” You will now see a sub-folder named Contents. Go into that, then into “plug-ins.” Put compress.ny in there. Open Audacity (or re-open it if you had it open while you put the plug-in file in place), choose the “Effect” menu, then “Add/Remove Plug-ins.” Find the plug-in named simply “compress.” Make sure it’s enabled. After all that, you should see a plug-in named “Compress dynamics 1.2.6” in the Effect menu, possibly at the bottom. And there you go.

I have the same problem. I have Catalina (v. 10.15.7) and Audacity 2.4.2. I try to erase the file you recommended but no luck at all. Can you help me, please? Is there any other way to solve the problem? I’ve uninstalled Audacity three times.

Re-installing Audacity doesn’t help.

Go to ~/Library/Application Support/audacity. Copy the underlined part. In the Finder click on the Go menu then select “Go to Folder”. Paste that text into the dialog. Once there, delete the following files (if they exist): audacity.cfg, pluginregistry.cfg and pluginsettings.cfg.

The file you want to install is called “compress.ny”. Where is it? If it is in your Plug-ins folder inside Application Support/audacity then you should just be able to start Audacity, click on the Effect menu and choose Add/ Remove Plug-ins, find the “compress” plug-in in the list (note the lower case - it will sort near the end of the list), click Enable then OK and it should work.

If the file compress.ny is not in your Plug-ins folder, do this. Start Audacity. Click on the Tools menu, then “Nyquist Plug-in Installer”. Follow the directions. It should install compress.ny in your Plug-ins folder for you. The do Add / Remove Plug-ins (as above) and enable it.

– Bill

Hi Bill, thanks for your help. But, after deleting the files you told me the immediately appear again.
Maybe it’s because my laptop is on spanish version, what do you think?
It’s truly frustrating this situation. :frowning:

Yes, Audacity creates those files when it starts. The point is you have reset all your effects.

Did you try using the “Nyquist Plug-in Installer” (under the Tools menu) to install the compressor.ny file?

– Bill

Finally, after several trials I made it with your last tip. Thank you so much!