Chris's compressor not working

Hi all,
I have just tried the compresser plug in from Chris but it says "Plug in mal formed and yet there’s a .ni exstention at the end of the file.
Also here is the link to the audio I am trying to level.

Nyquist plug-ins should have the extension “.ny”, not “.ni”.

Hi Steve,
So sorry I spelt it wrong.
Here is the exact name from the plug in itself:
Kind regards

Here is the link to install Nyquist plugins: Installing Nyquist plug-ins

Hi all,
I tried the .ny plugin installer and adding it to the plug ins folder manually but no joy any ideas please?

Did you enable it after copying it to the plug-ins folder?

Does the plugin Compress &dynamics reflect in the Effect list?

Compress dynamics is the Chris name under Effects.

Screen Shot 2021-08-11 at 8.46.35 AM.png
I know. He could have picked a better name.


On my list it’s:
Compress &dynamics

Compress &dynamics

That’s its data and effects management name. The English name when you actually go to use it drops the ampersand.


Hi Caz,
I haven’t got the name you mentioned in the effects menu.
I get the faulty plug in message when I try to enable it via plug in manager.
An chance you could post a link on here to the one you use.

What is the full and exact message?

Here’s the instruction from the site:

How to install
Ensure you have the latest version of Audacity installed.
Download Chris's Dynamic Compressor plugin for Audacity (download the zip version).
Double-click the zipped file to open or extract it.
Move “compress.ny” to Audacity's plug-ins folder.
macOS: ~/Library/Application Support/audacity/Plug-Ins
Windows: C:\Program Files\Audacity\plugins
Linux: /usr/share/audacity/plug-ins, /usr/local/share/audacity/plug-ins, or ~/.audacity-files/plug-ins
Go to the Effect menu > Manage…
Find either “compress” or “compress &dynamics 1.2.6” and select it.
Click Enable.
Click OK.
Now, “Compress Dynamics” will appear in the Effect menu.

That’s out of date, it’s been years since Audacity Windows plugins lived there.
Their current address is …


Those instructions are obsolete and will not work with current or recent versions of Audacity.

Chris’s compressor is a “Nyquist plug-in”.
Instructions for installing Nyquist plug-ins (Windows) are here:

It’s more than weird. I installed the plugin upon this allegedly “obsotete” instruction - everything works just fine. Did I hear right? Is the Plug-in folder now at the new address?
What for?
But I also read ibid:

If you are a privileged user and you need to install a plug-in for use by multiple user accounts on the same PC you may also install Nyquist plug-ins to the Plug-Ins folder in the directory where Audacity is installed.
This is usually: C:\Program Files\Audacity.

I assume that answers your question?

I’m sorry, I have no idea, what was the need to move the plug-in folder from a habitual natural location.

“Best practice”.

Please return the folder into the original location.