Channel Mixer effect crashes Audacity

using Vista SP2
Audacity 2.2.0-alpha-15-jun-17

The Channel Mixer effect crashes Audacity. Happens in Preview or when applying the effect.
This problem started somewhere between the 09-May and the 15-Jun nightly builds.

Sorry I can’t remember where I picked up Channel Mixer, but Version says “n/a” so I guess there’s only one version.

Please test with a more recent nightly and see if the problem still occurs.

Sorry I left it a little ambiguous when I wrote “the problem started somewhere between…”.
It’s still present in the 1-Jul-17 build.

I just zeroed in on it. The problem began with the 1-Jun-17 build.

Can you give exact steps to reproduce the problem. I’m testing with “Audacity 2.2.0-alpha-Jul 3” Debug build on Linux, and I see no problem.

Looks like the July 3 build you’re testing with isn’t on the download page yet. With all the builds I tried, which include June 3 in case you meant that, I haven’t found a way to not have it crash.

For testing versions, I’ve been doing this:

Generate (noise, default params);
Deselect track;
Generate (noise, default params);
Make Stereo Track;
Select whole track;
Open “Channel Mixer” effect (default params);
Crash occurs.

I’ve been testing on Vista (SP2). Today after reading your post I tried to test one of the failing versions on Windows 7, but ran into a problem. I put the Audacity folder on the desktop as I normally do for testing, and since Channel Mixer doesn’t come with the zip I put it in Portable Settings\Plug-Ins, as I’ve been doing all along with Vista. After restarting, Audacity finds the .ny file, and I can enable it in “add/remove plug-ins”, but after clicking OK and re-opening the Effects list, it’s not there. When I go back to “add/remove plug-ins”, it’s disabled again.

I tried putting it in Audacity…\Plug-Ins, and Audacity didn’t find it. It finds the one in another installation of Audacity on the same computer, but not the one in its own folder. Also tried renaming the one in Portable Settings\Plug-Ins to *.yn. Audacity still shows a “channel-mixer.ny” in that folder, but there is none! If I enable the one it found in another Audacity folder, it’s disabled again when I reopen “add/remove plug-ins”.

I’m glad you spotted this problem DickN. Yes I can reproduce it on Windows (it does not occur on Linux). The problem is in Audacity rather than the plug-in.
A fix is on the way, but as a workaround you can use the Debug button instead of the OK button.

Should be fixed in the next nightly.

We’ve been over this before. You’ll need to delete pluginregistry.cfg if you change plugin versions and Audacity versions often for testing.


Why not use the published version: That is clearly marked “Version 3”.


I have not followed the logic of why some externally issued plugins out in the wild like Channel Mixer still use a Debug button (and so now write to the Log). Is the intention to remove the Debug button from Channel Mixer?

I see no crashes in the fix in the Nightly Build. But I don’t like that now (part of the fix or very recent change?), once I have used the Debug button in Channel Mixer in a session, every time I then Press “Preview” I have to look at the Debug output first before I can hear the preview.


Debug should not persist beyond running the effect with the OK button.


  1. Select an effect
  2. Apply the effect using the Debug button. The effect is now in Debug mode
  3. Select the effect again.
  4. Press the Preview button. The effect is still in Debug mode and the Debug window appears before the preview plays.
  5. Apply the effect with the “OK” button. The effect is no longer in debug mode, so the effect is applied without showing the Debug window.
  6. Select the effect again.
  7. Press the Preview button. The effect is not in Debug mode, so the preview is played without showing the Debug window.

The intention is that the Debug button should be used for debugging. “Release” plug-ins should be bug free, so there is no purpose for debugging, then, consistent with other types of effect, they will be released as “Release versions” without a debug button. The Debug button should be enabled in experimental, proof of concept and other plug-ins that are not yet release ready, so as to help reveal and locate bugs.

Some plug-ins, such as the Apropos plug-in ( abuse the Debug feature as a workaround for limitations in Nyquist plug-ins. My intention is to progressively improve Nyquist plug-ins so that this type of hack is not required.

The logic has not changed, but improvements to the logging now reveals a behaviour that previously existed but was hidden. There are pros and cons to the behaviour now being revealed. The “pro” is that it is now possible to debug preview, whereas that was not previously possible. The “con” is that after using Debug, the debug window is enforced until cancelled by running the effect with the OK button, and users may not realise why that is happening - however, debugging is not intended for “users”, it is intended to be a tool for “developers”.

OK well, at Step 3 in previous Audacity I did not see the Debug window (as you go on to describe as a pro or con).

The Debug button is a button not a checkbox, to my simple mind. But I don’t care given Debug is now rare.

What would it take then to make Channel Mixer good enough for release in Audacity without Debug button? I assumed Channel Mixer quite high up the list of plugins that could be in released Audacity.


Perhaps we should change it to a checkbox, but it’s probably a bit late in the release cycle for that.

I’d love to see a “channel mixer” in Audacity, but I think it would be better as a built-in effect with built-in channel meters and real-time preview.

As a Nyquist effect, I think we would at least need the controls to update when presets are selected.

Vista SP2, Audacity 2.2.0-alpha-Jul 9 2017

Just confirming that the crash doesn’t happen under Vista in the July 9 build. There is another bug, however, which I’m reporting separately since it’s unrelated to this one.

I also downloaded the plugin per Gale’s post above, and it’s the same as the one I’ve been using.
Both say ‘version 3’ in the comment, but Manage->About says ‘Version: n/a’.

  • DickN

That’s not implemented (yet) for Nyquist plug-ins, so they all say “n/a”