Change Tempo Effect Crashes

I can’t find this reported anywhere so I hope I haven’t duplicated. The Change Tempo effect on an hour-long project crashes all open Audacity screens. On reopening recovery seems to work properly without data loss. This has happened three times in succession.

This is a known regression issue for 3.0.0 (affects all Nyquist effects) - this has been fixed for the soon to be upcoming 3.0.1 release.


Different bug. “Change Tempo” is not a Nyquist plug-in, it’s a built-in effect.

Does the problem occur with one specific project, or is it a general problem that occurs in any project when the selection is more than an hour?

Which version of Audacity are you using? (look in “Help menu > About Audacity”)

OOPS :blush:

I just tested Change Tempo with a one hour stereo chirp and it worked just fine with 3.0.0 on W10


I’m not able to reproduce the problem either, indicating that we need more information to proceed.

Thanks for your responses. I’m using Windows 10 Home v.20.H2.

The crash happens whenever I apply the Change Tempo function, even on short stretches. I installed v.3.0.0 and as my first session imported three one hour .aup files. They’ve been saved as .aup3 files but I notice distortion spikes have crept in. Could they be corrupted as a result of the file format conversions?

Tomorrow I’ll reinstall v.3.0.0 and try to rebuild my projects.

I did a LOT of extensive QA testing importing old AUP files from earlier Audacities (even as far back as 1.2.6) and I nevere encountered such distotyion or spikes.


It’s possible that the tracks already had some invalid sample data, which would go some way to explaining the crashes, and would also explain the spikes in the converted project.

How big are these projects? (total size of the “_data” folder).

Please zoom in very close on one of the spikes in the AUP3 version and take a screenshot to show us.


I reinstalled v3.0.0 and resumed work; pleased to say I’ve not experienced any nasty spikes since I rebuilt the damaged projects. I forgot to mention that as well as the spikes and distortion, the sound levels rose to unacceptable levels. I’ve created 9 small projects in v.3.0.0 of 17-18 minutes each (compared with the hour projects converted from v.2.4.2) and all seems well. I applied the Change Tempo effect to one of those and it worked without crashing.

@Steve: the _data folders were in the region of 1¼Gb, each representing an hour of music. With so many small files I can see the scope for corruption.

I’ll report if anything changes, otherwise thanks Steve and Waxcylinder for your input.

CONCLUSION: After 35 years at the IT coalface nothing surprises me about computers. My guess is the first v.3.0.0 installation didn’t complete properly, otherwise Windows or a program running concurrently somehow corrupted it. Had the problems persisted I would have regressed to v2.4.2 and awaited a stable v.3. If the reinstalled version continues to work I won’t lose any sleep on it!

Thanks for the update.

There is a new version of Audacity scheduled for release later this month (Audacity 3.0.1). It contains some bug fixes so it is highly recommended for all Audacity 3.0.0 users to update to the new version as soon as it is available.

Thanks Steve, I look forward to the new release. Sorry to report that crashing returned today when I applied Change Tempo to a 1h 1m 11s file. After several occurrences I reinstalled v3.0.0. Change Tempo doesn’t crash but fails to take effect. The only change before the crashes is that yesterday I enabled the VyNil plug-in to experiment sometime. I’ve since disabled it but that didn’t cure it. I can get around the issue so I don’t need to regress to v2.4.2. I offer this because I remember from my developer days that the smallest thing can have the biggest effect!

Ensure that none of the audio tracks start before time=0.0
(audio in “negative time” has been found to cause problems for some effects in Audacity 3.0.0)

I regret to say v.3.0.2 has not fixed this issue.

I just tested on W10 with 3.0.2 and the latest alpha test build that I have and Change Tempo works fine for me (and does not crash) on a one hour stereo project.

And works fine on 3.0.0 too.

Update: but if I Timeshift the waveform so that some of it is negative time - then Audacity crashes at the end of attempting the Change Tempo.

This is a bug (we don’t like crashes) - I need to test with some other effects, particularly the Change **** effects - and then I will log this.

So there are a couple of workarounds:

  1. ensure all your audio is in positive time if you want to use Ctrl+A to select all the project before applying the effect
  2. Or zoom to fit the window and use click&drag to select just the audio that is in positive time - with click&drag you can’t select in negative time


Interesting, I’ll experiment to see the longest length I can change tempo without a total crash.

See my previous post Update (written as you were writing) about audio in negative time causing the crash.


Logged as P1 regression bug (it’s a regression on 2.4.2) Bug #2574
Change Tempo & Pitch with selected audio in negative time crash Audacity on windows (error on Mac)


Thanks, I remember that point earlier but none of the audio is in negative time (see screen shot). I changed individual segments(?) to achieve the exact hour.

Well that’s me stumped on your use case then Brian - I can’t make an hour of stereo fail with Change Tempo it it’s all in positive time :confused:

I even tried adding a load of clip boundaries as you have - but it still works OK for me.

But many thanks for helping me discover the Windows crash bug :slight_smile: :sunglasses:


If it helps, the progress bar moves to within a whisker of the end, then Audacity ‘thinks’ for a second or two before disappearing from the screen. No error message is displayed. Restarting Audacity offers to restore the open projects (successfully) to the state before attempting the change.

Many thanks for your efforts, Peter. I can work around it but please keep it in mind. :slight_smile: