Chains lists are unordered

Audacity 2.12 on Ubuntu… er… whatever the latest was yesterday, and I just did the upgrade to the latest today. No change between the two.

When I either Edit Chains or Apply Chains, my list is completely unordered. It seems to be totally random, but consistent (the list makes no sense, but it’s the same every time). I’ve tried starting with a completely empty Chains directory and then creating new ones, and the problem still exists – new chains just get put in the list somewhere, not in alphabetical or even chronological order.

This isn’t a problem on Windows.

I’ve tried setting the language manually to English, also tried using Default. I’ve checked the system font, language, and Nautilus file settings and have not seen any changes or found any clues. I have not seen this problem in any other file list in any other program I have used on this system.

Anyone have any ideas?

Mac does not have that problem either.

Audacity 2.1.1 on Ubuntu 14.04 behaves the same. It could be a bug in wxGTK. Clearly when you add an item in that list, some sorting logic is applied (below the built in MP3 Conversion Chain). But I can’t figure what the logic is.