Chain conversion crashes Audacity 2.2.0


I’m a big fan of the Chain conversion feature of Audacity but it doesn’t work with the new version anymore.
I use the feature to normalize and export files in VBR 1 but when I try it with the new version Audacity crashes.

The upgrade from Audacity 2.1.3 to 2.2.0 is substantial and there could be some incompatibilities with old settings. Have you tried making a new chain from scratch?

Doesn’t work. Same error.

Have you tried doing a normal export as MP3 (not from a chain)?
Does the problem occur with one specific project / file?

No, the export works with single files.

And it works with FLACs but not with MP3s.

It has been verified that there is a problem with some Chains. Developers are working on this now.

Thank you! :slight_smile:

A ha! Good to know. I will stop trying to ‘fix it’ myself :O)

Good luck and godspeed with the solution. THANK YOU.

And I have QA tested this on Windows 10 and macOS 1.13 High Sierra - now works on both those platforms - just waiting for a Linux test till I can formally close this bug as Resolved.


Hi - how do I get this fix? Is there a new version to download?

Is there a release date for the fixed version? Or a working beta version?

For Mac, there is a “Nightly Build”
Note that these are “alpha” builds, and although the current Nightly Build is the same as the release version plus a few bug fixes, that is not always the case. During the development cycle the Nightly Builds will frequently contain untested experimental features.

Nightly Builds for Windows were being made by Gale, who sadly passed away in August, so we don’t have these at present. We now have a volunteer to take over building nightlies for Windows, and hope that we will soon have regular nightly builds for Windows.

We don’t make binaries for Linux. For Ubuntu there is the unofficial “Panda Jim” PPA

Okay, thank you.

Is there a version for PC I can download that is stable and contains this fix?

I am not a developer so need to know if this is something sensible to do, or if I should just deal with it crashing every time I apply a chain and wait for your next full release (2.2.1)

Many thanks for your advice.

I suggest using the RC2 Release Candidate from here:

It’s extremely close to being the release for 2.2.1 (the only differences will be a README file that was omitted for Linux - plus some additional foreign language updates)


Yes but I guess this bug ( is still in there. Until it’s fixed I stay with version 2.1.3.

Yes that bug is still there (or the residual part that affects chains remains)

We managed to fix the non-chains use of File>Open to import a file so the the zoom to fit was restored - and will be in the upcoming 2.2.1 release

But we than discovered that there was a related bug that affected Chains:
This remains unfixed and will not be in 2.2.1.

I’m surprised you say you are sticking with 2.2.3 - Steve Daulton, who logged this bug, reports that it is a regression on 2.1.2 - i.e he believes that 2.1.2 is the last version where this worked properly. :confused:


I guess you mean 2.1.3?

I use it daily and I can confirm the bug IS NOT there, at least not on my machine. The zoom level while using chains in 2.1.3 is correct.
Clipboard 1.jpg

If you follow the link to the bug report in my previous post you will see that Steve definitely says it works in 2.1.2 but not in 2.1.3 :confused:

But nonetheless - whatever the version - it’s still a regression. :frowning: