Can't set shortcut

I’m on Audacity 2.1.2 (exe, Windows 10).
I’m trying to set a shortcut for: Tracks menu > Align tracks > Start to cursor/selection start
The shortcut I’m trying to set is: [
(Also tried setting: Ctrl+Shift+S, same result.)
The dialog warns about a conflict, I hit OK.
I see the shortcut in the tree.
I close the dialog with OK.
The shortcut does not work.
Opening Preferences again, I see that the shortcut is no longer displayed.
Tried to export shortcuts, and the key is not in the XML:
Edited XML and imported it – it said 4 shortcuts were imported, but not the one I wanted.
Also tried doing it in Administrator mode – no success.

Many thanks for the report. However this has now been fixed in our source code, so will be fixed in the next release of Audacity.


I’ve just tested the latest development code, and what andraaspar is trying to do now works as expected.
Testing the same in Audacity 2.1.2 confirms the bug.

Thank you for looking into it.

I have the same problem. The shortcuts used to work on my previous PC but todays move to a new Windows 10 PC and 2.1.2 and I can’t set anything new

Any idea when this will get resolved?

When 2.1.3 gets released - we’ve only just released 2.1.2 and no timeframe is set for 2.1.3 yet but it will be at least three months.