Can't send files from Audacity on Linux

I’m using the linux version of Audacity on Pop_os, and have been having a really bizarre issue where it’s been really difficult to send files exported from audacity to other people. I had made a few voice recordings to send to someone, but when i tried to drag and drop them into outlook or gmail i’d get an error along the lines of “did not attach file because it is empty” or “file is 0 bytes, not attached”. Tried sending them through Microsoft Teams and got a similar error. Tried sending them through facebook messenger out of desperation, the files uploaded but if you downloaded them the result was a garbled and corrupted html file and not the mp3’s I sent.

Tried re-exporting the recordings as wavs, same error. Tried zipping the files and then sending them, same error. Tried zipping them with a dummy text file, same error. You get the picture. The only solution I found was to individually attach each file on gmail using the attach file option (rather than dragging and dropping) which isn’t ideal as that’s my personal email. I’ve been using linux for nearly a year and never ran into this issue sharing files before, which leads me to believe it’s an audacity issue (this was my first time using audacity in this particular machine). Any ideas what the problem could be? Any help is appreciated.

p.s. apologies if this is the wrong forum, like I said I’m just not certain whether this is a linux issue or an audacity issue

Windows guy. You say it works when you

which leads me to believe it’s a Linux or Outlook issue.

Perhaps a Linux user will chime in…

I’m a Linux guy (though not Pop!_OS) and I can’t recall having that issue before. It sounds like it might be an incompatibility with your browser version and those services, at least with the drag and drop feature. What browser and version are you using?

I’m using the latest version of chrome (yes, I understand the irony in using chrome on linux). Out of curiosity I just tried installing audacity on my Arch machine, recorded a quick test file and tried uploading it in a few places (again, using the latest version of chrome), and had no issues whatsoever!

Are you trying to make Audacity speak directly with internet connected services? That’s probably not the best idea. Audacity doesn’t speak internet very well.

File > Export your sound file locally in perfect legacy formats (WAV, MP3) and using unconditionally perfect filenames: Upper Case, Lower Case, Numbers, Underscore, and Dash. No Spaces. Close Audacity and then push the file up to your destination.

That better?


No, I wasn’t trying to get Audacity to communicate with my browser, I was exporting the files and attempting to upload them manually


How long and complicated is the show? We’ve been burned with people who fail to mention they have 56-hour sound files. I don’t think you can do a multi-track WAV file.

Assume you’re using perfect filenames.
Export the sound file and close Audacity.

Macs have a “Get INFO” process which reads out a list of everything known about the file.

Do you have such a thing and are there any surprises?

Open Audacity and open the file.

If it does open in good order then we’re out. Your system may have problems.

The MP3 process dates back to the Paleolithic and has had multiple changes. Maybe your system doesn’t like the changes that Audacity uses.

“Assume you’re using perfect filenames.”

When I say things like that, it’s good to respond in English Words “Yes, I’m using perfect filenames.” Don’t gloss over diagnostic steps because “It can’t possibly be that, so we’ll ignore it.” You can get into very serious trouble with bad, awkward, or misleading filenames.


This topic was automatically closed after 30 days. New replies are no longer allowed.