can't select folder that contains ffmpeg files

After trying to manually locate the folder that contains the FFmpeg files, I noticed that the “open” button is greyed out. Because of this, I cannot locate the FFmpeg library.

Please help. What can I do to solve this?

I’m currently using macOS High Sierra Version 10.13.6

I’m also using Audacity 3.1.3

Attached are the screenshots.

Perhaps the same issue I installed 3.1.3 today. On windows 10.

Had this same issue, I uninstalled version t2 and uninstalled LAME. Installed the new shiney version 3, and no dice. I added the ffmpeg to my path, also did not produce that Marie Kondo feeling, gave up, uninstalled, rebooted, re-installed, still no joy. The “built-in” lame decoder is just not being “found”? Suppose we should start looking at the logfiles that I recall were someplace and try figure this out ourselves initially.

So, you click the “Locate” button, then the “Browse” button. This should open a standard “file-open” dialog box titled “Where is ‘ffmpeg.64bit.dylib’?” The “Open” button will not be enabled until you have clicked on a file or folder to open.

Note that if you have installed ffmpeg using the standard installer it will put the files in the appropriate folder and Audacity will find them automatically.

– Bill

This is the Mac support forum. That said, LAME is not ffMPEG. You need to download and install ffMPEG on your system. LAME is now built in to Audacity and you do not have to do anything to use it.

– Bill

Oh, I definitely clicked on a file or folder yet it’s still greyed out. Forget to mention that, my bad.

Ah , only noticed this after I hit submit. (I blame 'oogle) Thanks.

This might help. Click the Options button in the file-open dialog, then select All Files beside File type.
– Bill

I’ve selected all the possible options in the file type. Still, the open button is greyed out.

Please post a screen shot of the full file-open dialog.
– Bill

Here it is. Thank you.

I found the problem! I apologize how simple it was. Manually locating the ffmpeg file DOES NOT detect the ffmpeg file if you select the folder the ffmpeg file is contained in. Instead, it detects the ffmpeg file if you select the ffmpeg file itself. Thank you everyone for the help.

Because you were in column view the Open button does not activate if you have a folder selected. You just move one column to the right and select the file or folder you want. This is a Mac thing, not an Audacity thing.
I missed it because I never use column view.
– Bill