Can't see how to set up recording through Soundcard [SOLVED]

I am hoping someone can help, I have been using Audacity on my desktop computer without any problems, the instructions worked perfectly. I have a problem trying to set it up on my Toshiba Laptop, there just doesn’t seem to be anyway I can see ‘stereomix’ in the Recording tab of Sound. I have show disabled devices ticked and show disconnected devices ticked. It has microphone as default as the default and only comes up with another microphone as disabled device. It has ‘Smart Audio’ as the sound program which doesn’t seem to have any way of changing it’s settings. I have realtek on my desktop and it was easy to setup audacity but I have no clue what to do on my laptop.

So you have been through the wiki postings we wrote?

You should probably know that Self Recording is not a guaranteed computer service. It rarely if ever shows up in computer sales brochures and some computers won’t do it at all — it’s been engineered out of the design. I think some Lenovo computers work like that.

Anyway, if you have one of those machines, you can use money-based software such as Total Recorder or money-based hardware such as the UCA-202, which is a stereo in and out USB sound adapter.


Thanks for your reply kozikowski

I have gone through the wiki postings but feel that there is probably some tweek I need to do to my laptop that I’m just not aware of. It might have something to do the the ‘Sound Audio’ program that it uses. I failed to mention in my initial post that I was just wanting to record podcasts through the soundcard. Frustrating that I can get it going so easily on my desktop. The total recorder program you mentioned, is there any reason why this would function rather than audacity?


If you’re using Windows Vista or later, the WASAPI method should work. Did you try that?
Here’s the link:

Hi Steve,

Thanks for your help, I have selected WASAPI as suggested but there doesn’t seem to be the loopback input available, If the input device box is the second box along all I have is Speakers Conexant Smart Audio as the only option.

On Windows Vista, Windows 7 or Windows 8 only you can choose the Windows WASAPI host (in the first box in Device Toolbar) and then the (loopback) input in the Input Device box. Choose the loopback input for the computer sound device you will be listening to (for example, “Speakers (loopback)” ). The loopback input records computer playback even if your sound device lacks its own stereo mix or similar input.

Please post the contents of “Help > Audio Device Info”.

The output device box is the second box, and the input device box is the third box.

  1. Open Device Toolbar .
  2. In the first (Host) box of Device Toolbar, choose “Windows WASAPI”.
  3. In the second (Output device) box in Device Toolbar, choose the Speakers or Headphones that you are using for listening.
  4. In the third (Input device) box in Device Toolbar, choose the (loopback) input for the same device you chose in step 3. For example, if you chose “Speakers” in Step 3, choose “Speakers (loopback)” in this step.
  5. In the fourth (Input Channels) box in Device Toolbar, choose mono or stereo.
  6. Start playing the audio you want to record.
  7. Press the big red Record button in Audacity.


Hi Steve and Gale

Thanks for your help, I followed the instructions in your post Gale and thought that there wasn’t loopback available initially because of the long description in Box 3 you can’t see all the words unless you hover over it. It seems to work perfectly now. Appreciate your help guys.