Can't save projects


We are having problems in our school with students being unable to save projects in Audacity. This is a new issue which seems to have started recently (in the last month or so) so it could be due to a Windows security update or some other thing.

When any student tries to save a new project, after typing in the name of the new project they get a “Cannot save project … disk may be unwriteable or full” error message. This error message does not happen on my administrator login.

All machines are Win 7 SP1 64 bit. We were using Audacity 1.3 beta but on two machines I have uninstalled that and tried 2.0.5 and we get the same problem. Our server is Win 2012.

All student accounts have mandatory profiles, but those have been in effect for over a year and we did not have this problem last year.

Any assistance or suggestions would be gratefully accepted!

Thanks very much


Sometimes a new Audacity install will try to save Projects in the same directory as the program itself. It’s no surprise that Windows may take exception to that. Make sure your target for saving has the right permissions. This is even more likely because you as administrator seem to work just fine.

Also remember computers can randomly be sensitive to punctuation marks inside filenames. Dates are a common failure. Today is 2014-06-10, not 6/10/14.

Letters, numbers, dash and underscore are pretty much the only safe characters.


Check “where” they are saving the projects.
Avoid trying to save to a network drive. Network congestion can make the location appear to be inaccessible.
Check with your IT department what locations on the computer’s local hard drive the students have write access to.

Thanks for both your suggestions.

Students have no write permissions to the C drive (except maybe to the appropriate C:users folder). Each student account has folder redirection active, so their My Documents is pointed to a personal folder on the network drive. It’s been like this for ages and only started playing up now. Any changes to their appdata or to their profiles will be lost when they exist (mandatory profiles).

I’m careful to use simple names like Test or Bob and the same thing happens.

I have tried changing the working directory and gotten more errors, I will check this and post back with the exact wording. Also, is there a default save location option?

Thanks again


It would appear to be a permissions issue, but Help > Show Log… in Audacity would confirm if access was denied.

No, but the last used location is saved (at least for a time) in the Windows Registry and could be forced before launch of Audacity. See: and on to the end of that topic.


I had no idea Audacity had a log feature! brb …

Okay, so after trying to save under student login, I get 3 error messages generated and nothing else.

The first one is “error 183: can’t create a file when that file already exists” and this is the most puzzling error message.
The location quoted in the error message is \domainschoolstudentstudenthome
when it should be \domainschoolstudentstudenthomestudentnamemy documentsprojectname

In other words Audacity seems to be trying to recreate the ‘studenthome’ folder (which already exists and which students don’t have access to). There is no mention of it trying to create the projectname folder.

The second error is “Error: mkdir in DirManager::MakeBlockFilePath failed (error 0: the operation completed successfully).”

The third error is “Error: failed to copy the file” and it lists the temp file from the appdata path as the source, and this as the destination:

Since the project name folder hasn’t been created (first error) it sort of makes sense that it failed when trying to copy the .au file to a non-existent folder.

Does this help?



If you had it working before you may want to investigate what you or Windows changed. Audacity did not change.

The official recommendation is not to save or export to network drives, but either way, it would appear your folder redirection is messed up.