Can't save EQBackup.xml [SOLVED]

Try to save an equalizer setting as a preset, but get a message “Couldn’t write to \etc\Audacity\EQBackup.XML Error opening file”. I get same message when applying an EQ preset such as Bass Boost, but it will then run anyway. I checked and the actual EQBackup.xml file is where it is supposed to be. The permissions give me read and write. Any suggestions?

I suggest you read the pink panel at the top of the page and give us the requested information. Install the latest Audacity 2.1.0 from Audacity ® | Free, open source, cross-platform audio software for multi-track recording and editing. if you don’t have it already.

The problem may go away if you restart the computer, otherwise try deleting EQBackup.XML then Audacity should recreate it when you next change the list of curves.


Using widows 7 and Audacity 2.1.0
Removed the EQBackup.xml file and the reinstalled Audacity (.exe). It now placed a new EQBackup.xml in there but Audacity still won’t save an equalizer preset. It still gives me the “error opening the file message”. It still runs the preset equalizer routines after giving me the same message before it starts running.

Interestingly after I deleted EQBackup.xml (before reinstalling), Audacity was still able to run the pre-installed equalizer programs. I thought Audacity was getting them from EQBackup.xml.

Fixed it. I deleted both the EQBackup.xml and the EQCurves.xml. When I rebooted Audacity it reposted new files for both. Now it works - Thanks

No it gets the default curves from EQDefaultCurves.xml in the folder you run Audacity from.

Thanks for lettting us know. I was hoping to avoid deleting EQCurves.xml because you then lose your custom presets unless you can figure out what is wrong with that file.