Can't record with Audacity 2.3.3 on Mac OS X 10.15

I cannot record with the most recent Audacity version on my Mac OS X. I searched the forum and the issue appears to microphone permissions. However, when I go to system preferences, Audacity does not even appear as an app under the “Microphone” setting for me to grant permissions to. I am able to get recording going if I run Audacity with sudo via terminal (in which case I am granting permissions to terminal to use the microphone). Is there any way to force Audacity to show up as a program so I can grant it permissions? Have already tried deleting and reinstalling but I’m guessing some setting somewhere is messed up which isn’t fixed by a reinstall. I don’t know enough about the inner workings of the OS to begin to guess what to do here, and don’t want to have to run as superuser in order to record.


If your version of macOS is Catalina, Apple broke support for Audacity shortly after the last Audacity release. The workaround is here:
The next Audacity release will fix this problem.

Audacity is the bomb! As a busy VO artist, I use it exclusively…at least, I used to. That is until Apple pulled their usual BS and screwed things up with Catalina! I made a decent donation the other day in the hope all you wonderful, genius tech types would be able to figure out a fix. The workaround is so clunky when I’m laying down multiple auditions and in remote sessions. Here’s hoping there will be a solution soon…but meanwhile…THANK YOU! For this wonderful program! Everyone stay safe and healthy out there!

This has been fixed for the soon to be upcoming version 2.4.0 (early May)


Fantastic! Thanks to all involved!!!