Can't Record With Audacity 2.0 and Windows 7 Pro

Until a few days ago, Audacity worked perfectly on my Dell Studio XPS 7100 desktop PC. The PC has Windows 7 Pro installed. The audio card is integrated into the PC’s motherboard.

I replaced a bad hard drive and reinstalled Audacity 2.0 from the .exe installer. Audacity 2.0 is now unable to record audio in spite of my duplicating the preferences I had set on Audacity before my hard drive crashed. When Audacity worked, I’d open Preferences and then the Devices window and used the following settings:
Host: Windows Direct Sound
Playback: Primary Sound Driver
Recording Device: Primary Sound Capture Driver

Now, the field to the right of the recording device says “No devices found.” In other words, it’s unable to detect my audio card. The audio card appears to be working properly as I’m listening to music and sound both from my hard drive and from the internet.

I’ve tried some fixes suggested in Audacity’s help tutorials. So far, no results. Can you suggest what I should try now?


Go into the Windows Sounds control panel and ensure that there is a recording device enabled. See here for details:

Thanks. I did that but to no avail. I finally got it working, though. Dell provided some drivers to me and Audacity can now record. It’s funny though, how the first time I installed them, they didn’t work. Only after two tries did they work.