Can't record web-audio in Audacity 2.2.0 in Win 10,

Can’t record web-audio in Audacity 2.2.0 in Win 10,
I believe Audacity needs to be fixed to allow web recording like it used to in older versions of Windows.
I can record web audio using another program called FastStone and I have spent 12 hours trying all the internet solutions with Audacity.
So I have done all the obvious things.
More information follows:
I have the latest versions of Windows 10 & Audacity= 2.2.0.
I right click the “Speaker Icon” in my tray and select “Playback” or “Recording Device”.
The PLAYBACK tab shows one & two green bars on far right side of screen (see below) & I can hear the sound from my speakers.
But the RECORDING tab {for either of my “Stereo Mix” devices} has no sound and no green bars on the right side of the screen.
Even when I go into Properties, select the “Levels” tab, & move the level from zero to 50 I still don’t get any sound.
For some reason, the level reverts to zero after a few seconds?.
Windows 10 also tells me the best drivers are already installed when I ask Windows to search for a newer driver.
I disabled all the microphones.
I ran the windows troubleshooter & it told me the audio device was muted & it was fixed, but still no recording sound?.
I am guessing this might be the Level gauge that reverts to zero after a period of time when I move it up to 50?

NOTE- I had pictures of the Windows popups to show the configurations I had tried (but they did not paste here) to I will try the upload attachment below
Audacty Problem.rtf (1.44 MB)

But the RECORDING tab {for either of my “Stereo Mix” devices}

With Windows 7 or newer, use [u]WASAPI loopback[/u].

:smiley: :smiley: Thank You Very Much. By picking the Host as WASAPI and picking a Recording Device that had LOOPBACK I was able to click the recording meter and see the levels as I recorded the web/YouTube waveform in Audacity. {ref is Audacity Manual: (; ) adf.

I have a similar problem. I have just replaced my laptop and now use Win10. On my previous laptop, with Win 8.1, I could record web music (for personal use!) using "Stereo Mix (IDT High Definition). However, I now have only two options - “MS Sound Mapper” and “Microphone (Realtek High Definition)”. Both of these record only from the inbuilt microphone. I have tried to attach a copy of the screen prints from each laptop!

I tried uninstalling 2.2.0 and then installing 2.1.0 as on my previous laptop, but it made no difference. I have now re-installed the latest version. If anyone can provide me with advice, or an alternative programme that will do the job I want done, I will be most grateful.

Thank you. :slight_smile: