Cant record system audio after upgrading sound card

Hi all. I am no longer able to use Audacity to record system audio as I once was. The M-Audio card I used to have worked w/Audacity just fine for a long time, but I can not record anything with my new RME HDSPe AIO. I have tried every single option available, but nothing. Using W7 Ult 64-bit and Aud v2.

Was hoping someone might have an idea.

Thanks in advance.

Anything in here helpful?


Thank you for the reply.

No - nothing there helps. I did see the “Windows Control Panel for sounds” section, but there is nothing there that helps, as the RME is already selected as the default device there.

So, in Audacity, I have selected:

Analog 1&2 (RME)
2 (Stereo) recording

In my RME Mix Panel, I see the audio

This worked fine with the other sound card; I cant understand what happened here.

And here are two shots of my RME control panel, and my setup:

Please, give us the exact Audacity version (all three numbers) - see the pink panel at the top of the page. Don’t abbreviate. If yours really says “v2” it is a bogus version not made by us.

The current Audacity version is 2.1.1

Where is the system audio playing? If it is playing on the RME device, follow the information Koz gave you. In Audacity set the

  • host to Windows WASAPI
  • playback device to the RME output you want to use
  • recording device to the (loopback) choice for the RME output you chose as playback device.


You also need to route the channels you want to record in Totalmix. Hit the X key and set the number of inputs you need. Then open Audacity and select the RME for input and output.

You M-audio is a very simple thing, compared to the RME that allows you to route anything to anything, including system audio. In Totalmix, you’ll get inputs and outputs, but also software playback. And all of that can be mixed and routed anywhere.

You really need to study the manual a bit.

Ok, got it.

In Audacity set the host to Windows WASAPI

That did it. Not exactly sure why it didn’t do it yesterday - maybe I just needed a reboot?


You need to hit the X key to switch from mixer view to routing view in Totalmix.

In Audacity, you need to select “analog 1+2” as the incoming recording signal.

Also, we need to know versions. Is your firmware on the Hammerfall up-to-date and are your drivers the most recent?