Can't record multiple tracks!

When I open a new session, I can record 1 track and everything works fine. Or I can assign a click track to the first track. After that, the Shift+R function isn’t…functioning. I’m running the latest Audacity download (3.2.4) on my Windows 10 desktop computer with a 3.5ghz processor. When I press Shift+R, a new track appears and recording seems to start for a fraction of a second (the green ‘play head’ arrow turns red and then instantly back to green, the ‘stop’ button becomes active and then instantly inactive again). Sample rate set in Windows Sound Control Panel recording tab and sample rate in Audacity project are both the same (4800). In all the tutorial videos I’ve found, the user presses Shift+R and recording begins on the second track. I have also tried uninstalling and redownloading Audacity to no avail. I’m getting frustrated!

I just solved this problem. I changed the “Host” on the Audio Setup menu from MME to Windows DirectSound and everything is functioning as expected.

Second update…The problem continued after my first “fix,” only slightly differently. I could Shift+R a second track ONE TIME. After that, it would do the same thing as before; create another track but not record to it. I now have it working consistently. I had to unplug the headphones from my interface (M Track Solo) and plug them directly into the computer, then change the Audacity playback settings to send the sound out the computer speakers instead of the interface. Hope this helps some random person in the future.

Yes, there have numerous reports of users not being able to get overdub working with the M Track Solo.