can't record more than 1sec on Windows 7 Audacity 2.1.1


I have just set up a home studio and could use some help. I have followed the setup instructions provided by Audacity (version 2.1.1) and all seems to be working except when recording it only records about a second and stops and starts and same with playback. Please can someone advise me why this might be (I don’t have overdub, software playthrough or sound activated checked)??



Please say more about what the home studio equipment is (makes and model numbers) and what you are actually recording.


I am using the sontronic stc 20, focusrite 2i2 interface, akg headphones and Windows 7 Asus computer. I downloaded all the software and all the equipment seems to be working it is just audacity that I seem to be having the issue with. Any thoughts?

What you describe is probably a buffering issue. Don’t be too ambitious with buffer settings or high sample rates. Leave Audio to buffer in Audacity’s Recording Preferences at 100 ms, or even increase it.

Don’t go above 96000 Hz project rate (bottom left of Audacity) which is the 2i2 maximum sample rate. You could use the default 44100 Hz project rate, which for the computer is less than half the work of 96000 Hz.

Don’t play games or run resource-intensive apps while playing or recording.

Sometimes, all you need to do is restart the computer.



But have restarted the computer and have only been using the default settings of 44100 and 100ms and the problem is the same. (this is just for voiceover so am not trying to record instruments or anything too technical just my voice). Is there something I might have pressed that would mean it would only record in snippets?


ooh also, have just noticed that I now can’t watch videos on my laptop (tried to watch the Focusrite tutorial vid) do you think this is an issue with my laptop rather than the software and equipment as have read every troubleshoot FAQ I can find to do with buffering and nothing works???


Then try increasing the Audacity “Audio to buffer” above 100 ms, as I also suggested.

If you had enabled Sound Activated Recording by mistake then recording could pause - the recording cursor would stop and the blue Pause button would be engaged (down).

You could try reinstalling Audacity and ensure you tick (check) the “Reset Preferences” box half way through the installer, then confirm when you launch Audacity that you want to reset preferences. But that will set Audio to buffer back to 100.

So what happens exactly? We cannot see your computer, so we only know what you tell us.

Have you read the manual for the 2i2? Have you installed its drivers from the installation CD that comes with it? Also there is a later 2.5.1 version of those drivers at You could try installing those 2.5.1 drivers.


Hi Gale,

I appreciate that you can’t see my computer - it’s frustrating as I don’t know how to describe what’s going wrong, a friend who has her own home studio even came over and couldn’t work out what was wrong either as everything is setup to the book. I do think it is something to do with the buffer as now when I press record, the recording line with mini arrow on top which is usually green and moves along when recording is red and stays still so clearly isn’t picking up anything at all (before there used to be a single line and occasional waves of sound but it was stop start) now there is nothing (please see attachment I have Print Screened my Audacity for you). I have tried amending the rate to 125ms still nothing so put it back to 100. I haven’t got sound activation checked but the cursor is on -58 I think (also see attachment). Outside of Audacity just on Internet Explorer, I have tried playing videos and again they freeze as though buffering but never play and doesn’t even have a symbol (eggtimer or that dashy circle) pretending to buffer it has just given up- my internet connection is fine (although I shouldn’t need that to record anyway should I?) but I can’t help feeling they are linked as I used to be able to watch videos fine on this laptop. I have been through the troubleshooting FAQs on Focusrite to no avail - the only thing I can’t do is watch the tutorial - but I downloaded the driver 2.5.1.exe restarted my computer and all seemed to be fine, it automatically linked when I set up Audacity. I just can’t record on audacity or stream videos.


It doesn’t allow me to attach the document with my print screens on - what are you allowed to attach to these posts then?

Please see here for how to attach files:

It is best just to attach the separate images, not a document with embedded images. You can’t necessarily attach all kinds of documents, and there is a size limit of 2 MB for each attachment.


It means the recording is stalling, not that there is necessarily no signal to pick up.

Then try it higher. :wink:

You don’t need an internet connection to record voiceovers.

Your computer could simply be too busy or out of resources to play videos or record. Have a look at Task Manager at your RAM and CPU usage. Quit un-necessary applications and services.


How high can it go? I put it up to 250 and still nothing.

I have tried attaching the print screens as images but I just get an Error 503 message - technology hates me clearly :confused:

“Have a look at Task Manager at your RAM and CPU usage. Quit un-necessary applications and services.”

As you probably have worked out by now am not the most tech savvy person. have closed down unnecessary programs but unsure what applications and services to quit on my Task Manager without killing my computer :blush:

Yay seems to be working! let me know what else I can print screen to help
audacity 2.png
Audacity 1.png

I’m glad it’s working for now. Did you change any setting in Audacity to make that happen? Do videos play now? If videos play, I think that indicates your computer is too busy.

Not to alarm you, but have you done a deep anti-virus check recently? Viruses make the computer extra busy and cause weird behaviour.

I see that you chose Windows DirectSound host in the image where recording stalled. You might get a more consistent experience with MME host, which is the most compatible. MME has the most latency, but that does not matter if you are not overdubbing.


Haha sorry when I said yay it’s working now I meant attaching the print screen images - nothing has changed with my recording - sorry for the confusion. Still in dire need of a solution. Will change it back to MME (I tried all of them and nothing seemed to make a difference). Will also do a virus scan as that probably wouldn’t help situation.