Cant record in old projects, cant save or export any project

I discovered my issues when I opened a Audacity project file that I haven’t opened for about a week and wanted to record something new on it. When I did so, it recorded for about 5 seconds and then gave the following error: “Audacity failed to write the file. Perhaps C: is not writable or the disk is full.” I have more than a TB of open space on my hard-drive right now and have had no issues with Audacity until today.

I can however record in a new file without receiving that error but can’t save or export it. I went back to try with an old file and can’t save or export that anymore as well. When I do try either saving or exporting it gives me an error that states the file path where I am attempting to save/export to, followed by “File not found. Check the file name and try again.” This happens with files with spaces in the file names and not. I tried changing the names to get rid of the spaces but that didn’t fix anything. This issue also happens with files that never had any spaces or special characters in them.

The audio in all the old files can be played in Audacity without issue. If I click X in the top right to close the file and get prompted to save, it returns “Could not create safety file: C:\Users\etc…” (file path ending with .aup.bak so I can’t save that way either.

I have tried the following things in regards to trying to resolve my issues:

Restarted my computer twice.
Delete the preferences config file in appdata.
Uninstall the version of Audacity I was using (2.2.0) and updating to the latest version (2.2.2) while ticking the box to refresh the preferences
Uninstall 2.2.2 and reinstalling 2.2.0 while still ticking that box
Opened the aup file in notepad to make sure it was using the correctly spelled data file with projname=
Changing the location of the save/export to my desktop
Change the location of the files to the desktop and opening them from there

I am running Windows 10 on a computer for personal use (not running audacity over a network), and am running it as an administrator. Thank you for the help.

“Audacity failed to write the file. Perhaps C: is not writable or the disk is full.”

Sometimes you can get that error when Audacity is trying to write to the system area. The System will not like that. Try managing some of the work from the desktop rather than where you normally do it.

You can also get that error if you used odd symbols in the filename.
Upper, lower, numbers, underscore and -dash- are the only unconditionally safe characters for filenames. I don’t use spaces, either.

2018-02-24 is today’s date, not 2/24/18.


I’m not completely sure what’s meant by this. When the files are moved to and opened from my desktop instead of the default folder, the issues remain. I’ve only ever saved to the default folder Audacity creates in documents.

I think I’ve figured out my issue. I switched anti-virus programs the other day and the new one I was using was somehow stopping Audacity from doing the things that I mentioned. I can’t believe I didn’t think about that sooner. I appreciate the prompt response and apologize for wasting your time. Thank you!