Can't record from PC [SOLVED]

Suddenly, after years of untroubled recording from my PC using a Behringer U-Control, I can’t record anything. The recording volume meter on Audacity reverts by itself to zero for no reason I can think of. I’ve even tried uninstalling and downloading a new version. No difference, every recording just flatlines. Anyone any ideas about what might be happening? I’m using Windows 10.

Check the settings for the U-Control in the Windows Sound Control Panel.

Already done. Seems to be the right setting. Any other ideas?

The only version of Audacity you should be using is 2.1.3 from

Are you choosing the Behringer as recording device in Device Toolbar?

How long is it since you cold booted Windows? Windows button, Power button, hold Shift on your computer keyboard and click “Shut down”.


Thanks, Gale. I do have the correct version and I do have the device on the appropriate toolbar. I have restarted Windows a few times, but I haven’t done a full shutdown in this time, so I’ll try that now.

No, rebooting didn’t work. It’s weird. Everything seems to be correctly connected and configured. I can hear the playback from the source (for example, BBC iplayer radio or Spotify) but when I come to record what happens is a) the recording meter defaults to zero, so I have to slide it up manually; b) even at full volume on the recording meter I am recording nothing, just a flat line. No error signals either. And the device is showing its correct lights - green light for on, red light under the optical input button. It just ain’t working.

I can hear the playback from the source (for example, BBC iplayer radio or Spotify) but when I come to record…

That makes a difference… The Behringer is for recording from analog sources outside the computer.

If you want to record streaming audio or the sounds coming out of your computer speakers, select [u]WASAPI (loopback)[/u].

That seems to have fixed it. Thanks, folks, you are audio stars.