Can't record from EZCAP218B

Not wanting to hijack this thread, but I’m having similar, if not the same problem, with Win 8.1 trying to record on laptop from EZCAP218B. I somehow got to recording again, but with other problem(s), but don’t know what I did. Now I’m back to Audacity not recording.

We can’t help two people with different computers and equipment in the same thread. Split to new relevant topic.

We cannot see your computer nor tell you what you did. I suggest you post the information from Help > Show Audio Device Info… . Please see How to attach files to forum posts. Then we can see the devices Audacity sees.

Also tell us what the “other problems” are exactly.


audioDeviceinfo.txt (4.86 KB)
Windows 8.1
Audacity 2.1.3
Input Device Cassette Player EZCAP218B

I’m trying to save my cassettes to MP3 files. Audacity 2.0.3 was included by EZCAP manufacturer. Had problems, posted to this forum and was advised to upgrade to current version of Audacity. Uninstalled, rebooted and installed Audacity 2.1.3. Settings to EZCAP recommendations except “Project Rate” at 48000 instead of 44100 Hz.
Playback through laptop speakers sounds a lot like Alvin. Also noticed that the indicated recording time doesn’t seem to match my watch. Playback time is another, different real time. The sound through the speakers while recording seems different from the playback from the recorded data.
In trying to find settings to fix this problem, I tried to adjust the Project Rate, save and close Audacity, reboot the PC, and restart Audacity. Start the cassette player, hit record and the waveform doesn’t appear (the timer doesn’t start?). Haven’t yet discovered how to get Alvin back.
Noob thanks you for your help.

How does the audio sound played out of the EZCAP when recording? Is it correct pitch?

Set Speakers / Headphones (Realtek High Definition Audio) to 48000 Hz as Default Format in Windows Sound and use MME Host in Device Toolbar. Set Audacity Project Rate bottom left to 48000 Hz.

Or, in addition check (tick) both “Exclusive Mode” boxes in Windows Sound for Realtek Speakers/Headphones. Leave Default Format as is. Move to the “Recording” tab of Windows Sound and set the “Microphone Array (USB PnP Audio)” - assuming that is EZCAP - to 48000 Hz Default Format and check (tick) both “Exclusive Mode” boxes on.

Then try Windows DirectSound or Windows WASAPI host in Audacity’s Device Toolbar.

Also do a proper cold boot. Hold the WIN (Windows) key and press the X key, then click on “Shut Down”. On Windows 8.1 this always performs a full shutdown.


The EZCAP is playing through the its headphones while I’m trying to record on the laptop. The screen capture shows the settings as you suggested, with the record button active, but no laptop recording.
Screenshot 2017-07-17 11.47.03.png
Since I’m still looking for why there is no laptop recording or sound being played through the speakers, I can’t comment on whether this affected Alvin or not.
I tried all three of the settings you suggested for MME,… Same results.
Thanks for your help.

Since I’m still looking for why there is no laptop recording or sound being played through the speakers, I can’t comment on whether this affected Alvin or not.

This is strange, but… Plug some headphones into the ezcap to make sure you’re getting sound and to make sure it doesn’t sound like Alvin.

Can you tell if you are “recording silence” and getting a “flat line” and a silent file, or if you’re not recording at all? (It sort-of looks like you’re not recording at all.)

The ezcap website say it has inputs for external audio, so make sure you’re set-up to record from the tape and not something external. (I don’t know how to select that.)

As I meant to state in my opening, I can listen to a normal sounding playback through headphones plugged into the EZCAP while trying to record on the laptop.
However, the timer isn’t moving on the laptop “recording” nor is there sound from the laptop while trying to record from EZCAP. Trying to playback from the laptop results in no sound.
The first thing that comes to mind is the EZCAP - USB cord is faulty. Two things argue against that: 1) I was successfully recording Alvin just before I started changing settings while trying to get a normal recording, and 2) why would the cord prevent the display of a straight line (no input).
Conversely, removing the USB plug and activating record creates a uniform waveform and sound from the laptop speakers, apparently the result of internal feedback. (I tried to get a screenshot, but prtscr isn’t working, perhaps because Audacity is controlling the keyboard? when the timer is running?)
I expect it is a noob error from my experimentation with the settings, but I can’t find it.
Thanks for your help.

Update: I still can’t record correctly, but I’m now getting high-pitched sounds from the laptop speakers while recording, and while playing back what the laptop recorded. I didn’t recheck the recording time and playback time against my watch, but believe that the recording time, playback time and my watch are each different. The speaker sounds differ depending on whether MME or one of the other protocols is being used.
Screenshot 2017-07-18 08.18.26.png
What I did to restore sound: 1) Uninstall Audacity, 2)Reboot, 3) Reinstall Audacity with preferences reset,4) Before plugging in USB, look for sound devices, 5) Restart Audacity, 6) Plug in EZCAP USB cord, 7) Restart Audacity and look for sound devices, which now includes microphone array, 8) Set preferences as shown in screenshot.
Conclusion: I have no idea what I did to turn off the input or the timers, but I can at least get back to ground zero, with the mechanical aspect apparently working. Still don’t know how to get rid of Alvin.
Thanks for your help.

I’m beginning to think your ezcap is defective.* :frowning:

I can listen to a normal sounding playback through headphones plugged into the EZCAP while trying to record on the laptop.

If you have access to a desktop/tower computer with a regular soundcard, you can connect the (analog) ezcap headphone-out to line-in on the soundcard and record that.

Or, you can get a USB interface with line inputs for your laptop (the Berhinger UCA202 is inexpensive) and either record the headphone output from the ezcap, or the line-out or headphone-out from any other cassette player.

Or, you can fix the pitch/speed after recording with the Change Speed effect. You’ll have to carefully time the real-analog tape playback time, and compare that to what you get in Audacity. (Or you can stop the recording after exactly 30 minutes, etc.). Then calculate and make the appropriate speed-factor or percentage change.


  • That would most-likely be caused by the clock/oscillator in the ezcap not being “exactly” 44.1 or 48kHz. …It’s the drivers’ job to make sure the hardware & application are using the same sample rate, or the driver can make a conversion. But, the driver doesn’t “know” if the hardware is bad/wrong.

Measuring indicated recording time vs. actual elapsed time suggested a 0.4 factor for “change speed”. That resulted in understandable playback, which may be sufficient for mp3 files. Don’t see how this helps get understandable sound while recording. Also don’t understand why this couldn’t be achieved with project rate or device rate adjustment. Any comments or educational links would be appreciated.
Thanks for your help and patience.

Summary. In my opinion, EZCap is cheap junk and it is inappropriate to blame Audacity or Windows.

If you care about your recording your cassettes, use a UCA 202. See and