Can't record due to output

I cannot record more than one track, and have narrowed the problem down to my output. I have Audacity 2.0.0, on Linux Mint 13 Cinnamon, on an HP DV6 I5 6gb system. I first thought it was a latency/recording problem, but as I was troubleshooting that, I unchecked the overdub box and that “fixed” the problem. I tried adjusting several of my audio out settings, but nothing really helped. What information is needed to diagnose this? I need the overdub to be able to record properly.

What are you trying to record? What equipment are you using?

Sorry, I meant to put that. Just some guitar recorded on a Samson C01U.
I had it running just fine on windows, there was a slight bit of buffer/latency problems. It would skip a bit on the output, but would go away when I adjusted the buffer.
I now have removed windows, and no matter what mic I record with (built in or the usb mic) it wont output properly.

“Software Playthorough” should be disabled (not selected) in the Transport menu.
“Overdub” shoud be enabled (selected) in the Transport menu.

What settings are you using in the Device Toolbar and what other options are available?

Typical settings I don’t usually change:
Software playthrough is off. Overdub on.
ALSA, default output
Samson mic, mono
Audio to buffer 100ms
Latency correction 0
32bit float

I have for output: default, dmix, hdmi, pulse, surround7.1/5.1/4.0, front, sysdefault, HDA Intel PCH: HDMI 0 (hw0,3), HDA Intel STAC92xx Analog (hw:0,0)

I have for input: default, pulse, sysdefault, Samson C01U USB Audio (hw:1,0), HDA Intel STAC92xx Analog (hw:0,0)

Which audi device do you normally use for audio output? (where does the sound actually come out when you play a track in Audacity?)

Comes from the front speakers: Analog Stereo Duplex in my sound driver settings.

Is that the same output as you get if you select “front”?
If so, try setting:
Host = ALSA
Playback device = front
Recording device = Samson C01U USB Audio

Ensure that no other audio applications are running. If you have had any web pages with Flash in your web browser, close your web browser, then restart Audacity. Ideally, log out and back in again, then try with those settings.

Wow, so simple, yet thats all it took. I never thought of changing those.
Thanks. Solved