Can't record computer playback in Audacity

I cannot get my copy of Audacity to record my computer’s playback anymore. I first noticed it with a copy of the 1.3 beta I was using and continued to have the problem when I downloaded and used the 2.0.2 release. I can get Audacity to record from microphones and other external sources, but it does not record anything if I select “Stereo Mix” as the input. I’ve gone through the tutorial and wiki page about recording playback and I think I’ve checked everything they recommend, but still don’t get any results. I’m running Audacity on windows 7. Any idea what might be wrong?

When you select “Stereo Mix” as the recording input in Audacity and you try to record something, does the red recording meter show any activity at all?

Nope. There’s no activity in meter or track being made just ends up with a silent line. No wave forms or anything.

Check in the Windows Sounds Control Panel that “Stereo Mix” is enabled and the recording level is turned up.
Check also what it says the recording format is - you should set the sample rate to the same as Audacity, which is 44100 Hz (CD Quality) by default.

Checked both. “Stereo Mix” is enabled and it was set to 44100 Hz.

Which implies that it worked previously.
Was that on the same computer? If so we need to try and find out what has changed.
Do you still have the same operating system?
If the sound card drivers have been updated through Windows Update you may need to roll them back to a version that worked.
Do you have a “Restore Point” from when it worked?

I was able to record playback on this computer in September and it has been updated through Windows Update since then. However, according to the computer’s device manager, none of my sound card drivers have been updated since then. Are there any other places I should look for drivers that might have been updated?

Thanks for your help, but I’ve managed to get it working again. It looks like I just needed to reinstall my computer’s sound card’s driver. It now works like it used to.