Can't record and playback voice audio while in Windows VM

I’m running Windows 7 in a VM, hosted on a laptop running CentOS7.2. I have a USB headset connected, and I’ve configured both input and output on the host to be the USB headset. I’ve used this setup before for some meetings, and people could hear me, and I could hear them.

I’m now looking at Audacity for recording an audio track over an existing video (and then incorporating that track back into the video).

I tried the “USB Recording” quick start page, but that isn’t helping.

For the three main dropdowns, I see the following:

  • Audio Host: MME. The get started page uses this, so I guess I’ll that.
  • Recording Device: Choices of “Microphone Array (VMWare Virtual …)” or “Microsoft Sound Mapper - Inp” (both of those are truncated, as I can’t see the entire value).
  • Recording Channels: 2 (Stereo)
  • Playback device: “Speakers (VmWare Virtual…)” and “Microsoft Sound Mapper - Out”

After I set these, I clicked the red Record button and started talking. I didn’t see any waveforms going up and down, so I assume it wasn’t recording anything. When I stopped the recording and then played it, it didn’t make any sound.

Any ideas?

Why do you need the complication of trying to get it to work in a VM?

What about the guest - can the USB headset be set as the default recording and playback device in Windows Sound ? Or can you configure the audio device in the VM? Audio support may be better and/or more configurable in some VM’s than others.

If Windows sees a named USB recording device you could try Transport > Rescan Audio Devices… in Audacity.

If you cannot get it to work, obviously installing Windows 7 in a partition and booting into Windows will work.


Gale

Uh, because? I have a Win7 laptop, but I don’t travel with it. I only travel with my Linux laptop, which I access the Windows VM from. This has to work in that configuration. I suppose I could simplify this by just using the audio recording tools on my Linux laptop, I was just sort of wired into the thought of doing the audio recording on the Windows VM, as my video editor is on the Windows VM (I wasn’t able to find the combination of features that I needed in a Linux video editor).

A bit off-topic, but you may be interested that there is a CentOS SIG (special interest group) currently being set up for audio production. There’s a bit of information about it on the CentOS developers mailing list: https://lists.centos.org/pipermail/centos-devel/2016-March/014511.html

Do you build from source on Linux? If so, my suggestion would be to try the current alpha code for Audacity (available on GitHub https://github.com/audacity/audacity) The quickest way to get the source code is to download the Zip file from that page. The alpha version is pretty stable right now and has a lot of new bug fixes since the 2.1.2 release. I’ve never tried building on CentOS, but from what I hear, once you get the dependencies sorted out it is fairly straightforward.