Can't record a new track when an existing track already displayed

Hi … My goal is to record myself playing along to a click track generated with the “Generate > Rhythm Track” function. I was told that I can do this. I’ve seen videos on YouTube of recording while playing a track. However, I cannot get this to work for me. Anytime I try to record something when there is an existing track being displayed, I always get a -9997 invalid sampling rate error as soon as I start recording. But here’s the kicker, I can record when there is no other track present. Therefore, I can’t have a sampling rate mismatch. Besides, I switched all of the sampling rates to be the same. (And even when they weren’t, I was still able to record audio.)

It just won’t record when there is an existing track displayed. I’ve tried with a generated click track present. I’ve tried it with a *.mp3 file imported. And even opened a new session of Audacity, recorded a first track, and then tried to record a second track. It just won’t work.

I’m working on a Windows 11 Home laptop, and I’m using Audacity 3.3.2.

Anybody have any idea what might be going on here?

Thanks times a billion,

Which ones, specifically?

Sometimes the hardware just wants to run at a certain rate. Sometime switching between 44100 and 48000 can fix this.

Also, sometimes switching between MME and WASAPI can fix the problem.

Are you able to play audio at this sampling rate?

That was it. I switched from WASAPI to MME, and now it works.

Thanks times many billions!!!


This topic was automatically closed after 30 days. New replies are no longer allowed.