Can't precisely select spot in waveform

When I try to select a spot in the waveform the cursor jumps a little bit to another location. I can’t seem to precisely select what I want to. What can I do to stop this?

Look to the bottom of the work window and make sure “Snap-To” is turned off.